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1 Introduction

Thank you for purchasing our product!

Your system is completely configured and ready for use. The present document provides full information on functionality of this unique set of tools for television production.

The VS2000 workflow for television production can be divided into two basic stages: preliminary work and actual camera shooting in LiveAction mode. Typically the preliminary work stage of television production using VS2000 includes the following steps:

· Developing scenario for the TV show or clip being prepared and selecting necessary video and audio materials, decoration elements, etc.

· Creating and exporting a 3D scene, or a set of scenes (virtual scenery, necessary animation of objects and virtual cameras) with the help of a 3D editor such as 3D Studio Max or Maya. An example of creating and exporting such a scene can be found in the user’s guide on 3D scenes creation; it is recommended to examine this guide on the whole beforehand.
· Creating a project containing ready 3D scenes in the HotActions. The most part of this document is concentrated on describing the HotActions application.

· Creating interface elements for controlling studio in the LiveAction mode of HotActions. For example, animation of objects or virtual cameras can be executed by pressing the assigned buttons or hotkeys. For this purpose a special HotActions script language is used. HotActions itself is an environment of interactive control which allows flexible configuration. Sections 3.1 and the following ones describe flexible configuration features; the script language is described in an individual document.

· Configuring input and output video and audio parameters using the HotActions application. These are described in the corresponding documents. Parameters of output video, such as television standard (PAL or NTSC) and output signal type, should be correctly adjusted by each user. If it is not required to change the studio operation mode, usually there is no need to adjust output video parameters another time. Adjustment of input video parameters is usually required after changes of the external equipment configuration. Chroma keying (rear projection) parameters may need to be adjusted for example if illumination in shooting studio has changed. Examples of input and output video configuring are in section 2.3.
Once projects are ready and input and output video is adjusted, it is possible to begin performance of the planned TV show scenario. Shooting is performed in the LiveAction mode of HotActions. Any necessary action or parameters adjustment can be executed directly during shooting either automatically according to the script, or interactively under the control of an operator. The LiveAction mode is also used during preparation for television production for checking availability of the virtual scenery being created.
Section 2 briefly describes a typical procedure of adjusting the system; it gives short instructions and information necessary for starting the system and achieving first results.

The following sections include reference guides for all software components of the system which fully describe interfaces and functional features of the current VS2000 version.
The VS2000 configuration described is the one with analog video output. The document describing details of assemblage and configuration adjustment is included in the VS2000 package if necessary.
Some typical problems and solutions to them are examined in section 10. We also recommend to regularly visit our Web and FTP sites (see section 10.6) where the latest versions of the software and documentation, new information, users’ questions and responses are available for your use.

2 Studio performance check
This section describes the way to check the VS2000 virtual studio operability and gives the essential principles of work with the HotActions application. The following sections describe the application in detail. Video and audio settings are described in individual documents.

2.1 Switching Studio’s components and connecting external equipment
First of all, the studio components should be properly assembled. Detailed instructions are included with the VS2000 package. Note important details on the scheme in section 11.1 which represents one of the simplest configurations. In particular, make sure that the DVI output of the graphics accelerator is connected to the DVI connector of DVM board, and FD300 board (or boards) is/are connected to special switching cables (Fig. 87) or to a Breakout Box. Types of breakout boxes are described in sections 11.2, 11.3 and 11.4. The signal from a breakout box connected to the FD300 board intended for image output usually goes to a TV monitor. Depending on studio configuration and output video settings, this signal may be component (YUV or RGB), S-Video, or composite. Sources of input video such as video cameras and video recorders are also connected to breakout boxes or cables.

Computer monitor, keyboard and mouse are connected as usual.

After making sure that the connections are correct, one can switch on the computer.
2.2 Checking Windows settings and starting HotActions
At work with the one-monitor configuration, the application main window and the Render Output window displaying studio image are shown on one monitor. If the Render Output window is absent, see section 10.4.8. XE "Display Properties" \b 
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In a configuration with two video adapters it is necessary to check whether the video adapter with DVI output (GeForce by NVIDIA) is connected and correctly adjusted for work with VS2000.
For this purpose it is necessary to open the Display Properties dialog (figure on the right), using Start->Settings->Control Panel-> Display Properties or a right click on the desktop and the Properties item from the local menu.
On the Settings tab page of this dialog from the Display drop-down list select the following item for the monitor 1 icon: 1. Plug and Play Monitor on NVIDIA GeForce 7900 GTX.
In the Color Quality drop-down list select Highest (32 bit).
For the monitor 2 icon select 2. Plug and Play Monitor on NVIDIA GeForce 7900 GTX from the Display drop-down list and enable the option “Extend my Windows desktop onto this monitor” located below in the dialog.
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In the Screen resolution group for the monitor 2 icon select 720 by 576 pixels for studio working in the PAL standard, or 720 by 480 pixels for studio working in the NTSC standard.
It is also necessary that the required standard be selected in the video adapter settings. For this purpose, do the following:
1. Press the Advanced button in the right bottom corner of the Display Properties dialog (see the figure on the left).
2. In the next dialog select the tab with the [image: image2.png]


 logotype and the video adapter name (GeForce 7900 GTX in the Fig. 1). In the settings menu appearing on the left select the nView Display Settings.

3. Select the monitor 2 icon in the dialog and press the Device Settings>> button. Select the Select TV format item on the context menu and specify the required TV format: 480p EDTV for NTSC or 576p EDTV for PAL format. 
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Fig. 1. Monitor settings dialog with the nView Display Settings selected; the Device Settings>> menu
If it is impossible to specify the required resolution for the second monitor, open the Monitor tab of the Plug and Play Monitor and NVIDIA GeForce… dialog; disable the option Hide modes that this monitor cannot display in the Monitor Settings. Open the List All Modes dialog from the Adapter tab using the button with the same name, and select the required mode.
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Fig. 2. Dialog of selecting the mode for the second monitor in NVIDIA settings
To work with a studio, start the main application – HotActions. This can be done with the Start menu (Fig. 3) or with a double click on the 
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 HotActions icon on the Windows desktop.
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Fig. 3. Starting VS2000 applications
The HotActions application is presented with the main window of the same name in which it is possible to control the studio, and the Render Output window. After the necessary output video adjustment in the studio is done, replace the Render Output window to the rendering output monitor connected to the FD300 board that is intended for the synthesized image output (see section 11.1). If the Render Output window is not displayed on the desktop, use the Center Render Window command from the Window menu of the HotActions main window to place it in the center of the main application window.
2.3 Video settings
Input and output video signal settings are adjusted in the Live Video tab of the Options dialog (Fig. 5) which is opened by clicking the 
[image: image7.png]


 button on the HotActions main window toolbar (Fig. 4), or with the Options command in the Tools menu.
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Fig. 4. HotActions main window toolbar
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Fig. 5. Live Video tab of Options dialog
Video settings are described in detail in a special document; here only the main steps of adjustment are mentioned.
At first, it is necessary to adjust output video. In the Output controls group of the Live Video tab (Fig. 5) on the right of the Format button there should be an indication of the working TV standard. It is possible to specify a different format if necessary, using the Format button to access the Format dialog.

The Mode button of the same controls group opens the Output Mode Configure dialog (Fig. 6).

The Analog Video Output controls group of this dialog is used for setting the output signal type (component, S-Video or composite). Default value selected from this list is ColorBar YUV+CVBS displaying test color bars. For more details about selecting output video signal type, see section 3.4.1 of User’s Guide on video settings.
From the drop-down list in the Mode group (Fig. 6) select the required mode of the application work. Select Genlock if your configuration provides synchronization of output video signal to an external device. The minimal configuration allows selecting only the No Genlock mode. See also section 3.4 in the User’s Guide on video settings for information about synchronization modes.
If your system provides synchronization, in the Genlock Internal Video group select a source of synchronization with video signal on Line B from the Source drop-down list. XE "Genlock" \b 
Accordingly, in the Select Video Source dialog (Fig. 7), which opens with the Source button of the Genlock (Line B) group, it is required to select the commutation index corresponding with the external synchronization device (see the Appendix, section 11).
It is recommended to keep the rest of the settings default at the first application session.
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Fig. 6. Output Mode Configure dialog, Genlock mode
If the format and type of the required output signal are specified correctly (Fig. 6), the second monitor displays the Windows desktop background. With the help of the mouse, drag the Render Output window to the second monitor. If the second monitor does not display anything, consult section 10.4.4.
The Input(s) group of the Live Video tab page in the Options dialog (Fig. 5) is used for adjusting the input video. It allows adjusting parameters of FD300 boards receiving input video signals.

The upper drop-down list in the Input(s) group allows choosing a board for adjustment. The number of items in this list (LIVE_1, LIVE_2, etc.) corresponds with the number of FD300 input boards receiving input video signals in the system. Up to two independent video sources  may be connected to each input board (to Line A and Line B). It is possible to input data only from one of these sources at the same time, but it is possible to switch between them at work. Thus, the maximum number of independent streams of live video in a scene is equal to double number of input boards in the system.
· If your configuration provides opportunity to work with several boards, the correspondence of indexes from the Input(s) drop-down list to the FD300 boards is determined once, experimentally.  For this purpose it is necessary to choose any number from the list; then it is required to set a working format (in the Format dialog opened by the button of the same name) and index of the video signal source input (in the Select Video Source dialog opened with the Source button – see Fig. 6). After that, see if the preview window of the Select Video Source dialog displays any image. If there is no image, the chosen number is wrong.

In the lower drop-down list of the same group Input(s) it is possible to specify efficient horizontal resolution for input video stream: Full Resolution (720 pixels) or Half Resolution (352 pixels). Vertical resolution in this mode is the same for PAL and NTSC, only the scaling coefficient is different.
For example, to adjust the first channel Line A of the first board LIVE_1 in the Full resolution mode, in the corresponding drop-down lists of the Input(s) tab select the required values and click Source in the Line A group. This opens the Select Video Source dialog (Fig. 7). In the Input drop-down list of this dialog select the correct index corresponding to the given signal. Other parameters of the dialog are intended for adjustment of brightness, contrast, etc. It is possible to restore the default values of these parameters by clicking the Default button. After receiving video image in the preview window of the dialog, you can exit the dialog with a click on OK.
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Fig. 7. Select Video Source dialog
Now it is necessary to adjust keying parameters (chroma key) for the chosen channel. On the Live Video tab (Fig. 5) of the Options dialog in the group corresponding to the channel (Line A) choose the Universal Key algorithm of calculating the keying table. Pressing Key Configure in the same group opens the KeyConfigPro dialog (Fig. 8) with settings for the selected algorithm. Details of this dialog and its adjustment are described in sections 5 – 7 of the User’s Guide on video settings. XE "Keying Settings" \b  The automatic method of constructing the table (the [image: image12.png]


 button) usually gives good results if illumination is sufficient and the background is of high quality. The Close button [image: image13.png]


  closes the KeyConfigPro dialog and loads the constructed keying table in the FD300 board.

It is necessary to make similar adjustments to the second channel (Line B) of the input board LIVE_1. In the Select Video Source (Fig. 7) you can choose the same signal as for Line A.

When exiting the HotActions, the video settings including those for the input signals switching and keying are saved. At the next session they are automatically restored. After the adjustment of both video channels for an input board is complete, it is recommended to save the parameters configuration as a Preset. XE "Presets" \b  For this purpose type a name in drop-down list in the Presets group of the Live Video tab in the Options dialog (Fig. 5) and click the Save button. For more details see the User’s Guide on video settings. If a configuration’s name was not specified, at exiting the application it is saved with a predefined name “AutoSavedN” where N (1, 2, etc.) corresponds to the number of the LIVE_N input board.
If there are other input boards in the Input(s) drop-down list (LIVE_2 etc.), it is necessary to perform the adjustment procedure for each of them. It is recommended to save configuration presets for different boards (LIVE_1, LIVE_2, etc.) under different names.
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Fig. 8. KeyConfigPro Dialog of the Universal key algorithm
2.4 Audio settings
External audio equipment is connected to switching connectors of the FD300 board for which a special cable (see section 11.1) or a breakout box (sections 11.2, 11.3, 11.4) can be used. All sound files played back in HotActions, for example WAV or MP3 files started at commands of a script, are produced at the sound card selected in the system by default. To combine this audio stream with sound from microphone or other sources, it is necessary to adjust system settings: XE "Sound Settings" \b  in Start -> Settings -> Control Panel -> Sounds and Multimedia -> Audio, from the drop-down list Preferred Device (in the Sound Playback group) select one of the output channels of FD300 board as the output device. The required mode of sound mixing in VS2000 can be set in the Sound Configure dialog that can be opened with buttons [image: image15.bmp], [image: image16.png]


 or with a command with the same name in the Tools… menu (see also the document on sound configuration).
2.5 Working with sample projects
Once input and output video as well as sound settings are properly adjusted and components and external equipment is connected to the system, it is possible to start working with the virtual studio. In this section the general outline of work with the virtual studio project files is described.
From the File menu of the HotActions main window select the Open Project… command. This opens a system Open dialog where you can choose one of the sample projects that come with HotActions.  Most often the sample projects folder is D:\VS2000\VS_Samples. Additional sample projects can be installed manually with the help of the corresponding installers. After the first run, the project name is added to the context menu of the Recent Projects command and it is possible to use this menu to reopen it.
Let’s select the project Sport located on D:\VS2000\VS_Samples\Sport\Sport.vsp.

Arrangement of windows corresponding to documents attached to a project is restored at loading a project in the main application window. A list of project documents sorted into groups is displayed in a project window named in this instance Sport.vsp (see Fig. 9). For more details about projects, turn to section 3.1.2.

The window with the title Sport.hot is used for the scene direct control. It is a Hotset containing HotBars – floating toolbars. Creation of such toolbars and work with them are described in more detail in sections 3.1.5 and 3.6.

To check the VS2000 availability, press the button Init 
[image: image17.png]


 initializing a scene. If the previous steps are executed correctly, in a few moments the Render Output window displays the scene with VS2000 output video. XE "Initialize Scene" \b 
Press the Start LiveAction [image: image18.jpg]


 button. This button is located on the second from the left toolbar of the main window and duplicated on the special hidden toolbar with large buttons which is shown and used at switching to the LiveAction mode. When the application works in this mode, the Start LiveAction button changes its appearance to [image: image19.jpg]


. XE "Start Live Action" \b 
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Fig. 9. Example of the VS2000 operation: the Sport project loaded
In the LiveAction mode the application switches to the Fullscreen mode by default, and all windows, except for Hotset’s windows, are hidden or minimized. The settings concerning the LiveAction mode are discussed in section 9.1.

Pressing the Play Sport button on the Hotset floating toolbar starts playback of the scene animation (Fig. 9). Names of the buttons executing similar operations in other projects are usually formed according to the formula: Play + project name. Buttons of another toolbar of this project (CAMERAS) are intended for managing virtual cameras.

Press the [image: image21.jpg]


 button. It executes switching from the LiveAction mode back to editing mode. Note that in the editing mode clicking a button of any toolbar only selects it but not presses. To test the operation executed by a button not switching to the LiveAction mode, click it with the Alt key pressed.
After the first test loading and playing back a sample, one can explore the VS2000 facilities step by step with the help of the following sections’ descriptions.
3 HotActions application
HotActions application included with the VS2000 software package is intended for creating and configuring ergonomic environment for interactive management of 3D graphics scenery together with video streams in the realtime operating mode. The application is presented by the main HotActions window, which provides media for managing a virtual studio, and the Render Output window displaying created video images.
As it was mentioned in the Introduction, working with the HotActions application may be divided into three stages:

· Creating commands of 3D scene objects modification and animation (changing their positions, textures, switching between virtual cameras, etc.); creating the corresponding interface elements for managing studio in the LiveAction mode.

· Preliminary configuring of input and output video and audio signals in the Live Video tab page of the application general settings dialog, directly from the HotActions; this is discussed in greater detail in another document.

· The shooting itself in the LiveAction mode with the help of the interface elements created for performing the script.

3.1 Basic notions of HotActions
To present the general idea of how to work with the application, we shall describe the basic means of work in it: Scene, Project, Action, Actions Library, Hotset, Hotbar, Theme, LiveAction.

3.1.1 What is a Scene?

A 3D scene is a set of virtual scenery (3D objects with or without animation, virtual cameras, light sources, etc.) created with a 3D editor, such as 3D Studio Max or Maya. A scene should be exported to the virtual studio and used there, which implies compliance to some requirements and upholding to certain restrictions. That’s why it is recommended to preliminary examine the Guide on 3D scenes creation. This document also contains a full-length example of exporting a scene and creating a project for it in the HotActions application.
The result of export procedure is a *.3d file (a scene document), that can be used in the HotActions application (see section 3.4).
Rendering a scene into the initial (basic) state, loading, initializing it and naming its requisite components is performed with dedicated initializing Actions (see section 3.4.7).
3.1.2 What is a Project?

General work with the studio in the HotActions application is organized by means of creating Projects.

A project file (*.vsp) contains references to all files (documents) used for work. It also contains information about the condition of files (open, hidden or closed), windows and toolbars arrangement and other settings, for example paths to files included in the project.
Only one project can be open at a time in the application. Closing a project window closes all the windows connected to it after a confirmation request for saving files. 
A window of any project contains standard groups. Standard Groups  XE "Standard Groups" \b are separate folders for each standard type of files with which HotActions works. When files are added to a project, they are automatically saved in the appropriate folder/group. The user can also create Custom Groups,  XE "Custom Groups" \b i.e. groups that are not assigned to any certain file type. They can contain any files used by a HotActions project, or, more precisely, references to them united on some basis.
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Fig. 10. Example of an open project window
Context menus appearing at a right  XE "Contextual Menus:How to open" \b click on a group name or a file in it allow to operate groups and their contents. A detailed description of project management can be found in section 3.7.

3.1.3 What is an Action?

After a scene is created with a 3D editor, such as 3D Studio Max or Maya, and exported (the procedures are described in detail in a special document), it can be used in the HotActions projects (see section 3.4).

Actions with control commands are universal, easily modified and transported tools of interaction with a scene.
Action is one or several text commands; the result of its execution is some modification in a virtual scene. This concept is basic in the HotActions. Actions, in particular, include: XE "Actions:Purpose" \b 
· the loading of files of scenes, textures, sound, etc.;

· the switching of virtual cameras;

· start/stop of one or several objects animation playback;

· start/stop of sound playback;

· change of scene elements’ properties (for example, visibility, scale, position, color, etc.).

One Action can invoke in sequence or simultaneously other Actions, which makes scene sequences.

An Action execution is initiated by the user (the operator of 3D scenery) with clicking on a Hotbar button (see section 3.1.5) or pressing a Hotkey on the keyboard in process of interactive control of the scenery (LiveAction).

An Action’s contents are edited in the Properties dialog (Fig. 16). Execution of the Action’s commands can be tested from this very dialog. For more details on editing and debugging Actions, see section 3.3. Actions creation regulations and a special language are described in the User’s Guide for script commands usage. A special group is initializing (Startup) Actions. They represent sets of commands automatically executed at switching to the LiveAction mode. The task of Startup Actions is rendering a scene to the initial (basic) condition, loading and naming the necessary components. For information about Startup Actions creation see section 3.4.7.

Actions are saved on the disk as text documents (Actions Libraries, see section 3.1.4).
3.1.4 What is an Action Library?

An Action Library is a set (library) made up of several Actions, incorporated in one document (a file with the *.acl extension). XE "Actions Library" \b 
As a rule, Actions are united in libraries by a common attribute; for example, they are assigned to the same 3D scene of a particular project. For this reason, in the majority of projects there is only one Action Library.

In most cases an Action Library is created by the scene designer/animator because of his better knowledge of the scene structure, and/or by the program director (see section 3.5 for details on work with an Action Library).

Since every Action represents an executed script of command, any Action can be associated with a certain button on the floating toolbar. To perform this operation in a new project, it is necessary to create at least one Hotbar.
3.1.5 What are a Hotbar and a Hotset?

Hotbars are button panels associated with a Hotset and directly used in the LiveAction mode as the basic interface for a scene control. XE "Hotset" \b 

 XE "Hotbar" \b 
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Fig. 11. Hotbar and Hotset: the basic tools in HotActions
Hotsets are sets of Hotbars. They are convinient for the capability to hide, show or move all Hotbars in it simultaneously.
Each button of a Hotbar have a corresponding reference to a certain Action. By default their names are identical. It is possible to add buttons to any Hotbar by dragging and dropping directly on it Actions from Action Libraries. If an Action is simply put on an empty place of Hotset, a new Hotbar is created. The work with Hotsets and Hotbars on the whole is described in section 3.6, and section 3.6.2 is dwelling particularly on operations with buttons of Hotbars.
Operations with Actions in a library are discussed in section 3.5.2. For details on editing Actions themselves, see section 3.3.

3.1.6 What is a Theme?

Theme is a specific type of document representing a description of project variables (parameters) which are used in its Actions. This enables the designer to vary project scenes appearance and behavior by changing values of parameters forming the Theme.
The values of parameters specified in a Theme are substituted at launching the Action in the following way: if a variable name is found in the Action (the Variable Name field in the Variable tab, Fig. 58), it is replaced with its value (the Value field in the Variable tab, Fig. 58). Thus, after loading a Theme at the Action start, new values of the variables are used.
It is possible to change a Theme in the LiveAction mode (see section 3.1.9).

There are two basic types of Themes: Standard and Custom. In the Theme drop-down list of the Project toolbar (see section 3.2.5) names of Standard themes start with an asterisk (*). The principal difference between Standard and Custom themes is that in the LiveAction mode the user can edit Custom themes (change their variables’ values), and Standard themes are available only for reading (loading). The user can also create a Custom theme on the basis of a Standard theme. Both types of themes are always saved in corresponding folders of the project folder.
All themes of a project are available for selecting in the LiveAction mode (see section 3.1.9).

· A project can have only one theme loaded. If it is not specified explicitly, the application loads the default theme (Default in the Theme drop-down list, see section 3.2.5) which is the last selected (saved) theme.
For more details on work with themes, see section 3.8.

3.1.7  Work with files
HotActions works with the following types of files:

· projects (*.vsp files);

· scenes (*.3d, *.dxf, *.wrl files);

· Action libraries (*.acl files);

· Hotsets (*.hot files);

· text documents (*.txt, *.ini, *.inf files).

To work with all files, it is necessary to create a Project in the HotActions application. A project file contains references to files of the other types and allows manipulating them, for example open them simultaneously or individually, hide, etc. (see section 3.7.2).

Usually all files included in a project are opened right at opening the project. Existing projects are opened from the File menu of the main application window with the Open Project… command. After a project was opened for the first time, its name appears in the local menu of the Recent Project command and from this moment it can be opened by selecting its name in this local menu. A context menu of a required group allows adding an existing file to the current project.
A window of any project has separate folders for each type of files – these are Standard Groups. It is also possible to create Custom Groups which are not assigned for any particular file type. Details about groups and operations with files in a project are described in section 3.7.2.

To open a file not included in a project, in the File menu select the Open…command. In the Open dialog select the file name from the required folder, having selected the file type from the drop-down list beforehand (Fig. 12).
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Fig. 12. System file open dialog
After this procedure it is possible to open files easier, with a left click on a filename in the local menu Recent Files/File. When opening a file, the application always requests whether it is to be added to the project if there is a project loaded.
New files are created with the help of the dialog opened by the New command in the File menu (Fig. 13), by pressing Ctrl+N keys, or by pressing the button [image: image25.bmp] on the window toolbar. In the New dialog it is required to choose a file type in the File Type field, specify a new file name and a folder for saving it.

[image: image26.png](@VS Proect V5 Froject Fs
8 Action Libay VS ActorLibray Fle
[t Hotst Parel VS Hotset Fle
[ElTe Document  TewtFie

¥ Addto Project R o




Fig. 13.  Dialog of creating a new file
If an opened file was changed and the changes are not saved, in its title bar after the filename the asterisk “*”appears. This symbol is removed after the first saving of the current file state.
To save changes in a file of any type, in the active window of this file use the Save command of the File menu, or an equivalent button 
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 on the toolbar. For saving a file with a different name, use the Save As… command. Changes in all open files (except scene files) can be saved with the 
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 button.

Details about each file type use are described in the corresponding chapters of this Guide.
3.1.8 The Properties dialog
The Properties dialog is used for displaying all available information about various scene objects, elements of studio control, project components, etc.
The dialog contents vary depending on the selected object.
The Properties dialog is opened in the same way for all objects in the studio: by pressing Alt+Enter keys or the 
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 button on the main window toolbar, or from the object’s context menu. When the dialog is opened, the button on the toolbar is in the pushed position. A second click on this button hides the Properties dialog. There is no need to close the dialog every time, it is enough to just switch the focus between the required elements to have their properties displayed.
By default the Properties dialog is displayed docked to the right border of the main window (Docking View) and it can be rendered “floating” and back with a double click on its title bar.
3.1.9 Edit and LiveAction modes of operation
The HotActions application works in two basic modes: Edit and LiveAction.

Right after the application is started, it is in the Edit mode in which the user performs all operations connected with preparing the environment for the LiveAction mode. These operations are: opening and closing files, creating Actions Libraries, Hotsets, Hotbars, Themes, setting various options, etc.
At switching to the LiveAction mode, the application requests for confirmation for saving changes in the modified files of a project.
The LiveAction mode is used for interactive management of 3D scenery (i.e. broadcasting, shooting, displaying). By default the application switches to the Fullscreen mode, and some of the windows are hidden or minimized according to the corresponding parameters settings in the application options (see section 9.1). During switching to the LiveAction mode, the application performs a search for a specific hidden by default Hotbar with a fixed name $STARTUP$; all Actions included in this Hotbar are started (see section 3.4.7). It always contains a special initializing Action (see section 3.4.7). It is necessary for executing a number of special actions for initializing a 3D scene, such as naming tracks’ fragments and others.
Note that a scene can be initialized at any moment with the 
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 button on the main application window toolbar.
· Particularly note that initializing Actions can be launched from $STARTUP$ of only open Hotsets! Names of the open Hotsets as well as names of other files are in bold type.
Usually, the user of the LiveAction mode is the virtual scene operator. The operator starts execution of Action commands by pressing Hotbars’ buttons. Actions’ commands can also be started by pressing assigned Hotkeys on the keyboard. A Hotkey can be assigned in the Hotkey tab of the Properties dialog for an Action on a Hotbar (see Fig. 39 in section 3.6.3). Objects of a scene can be controlled with joysticks or other control devices (see section 5) and through a network, with the help of the broadcast automation application.
Changing a Theme (see section 3.1.6) allows the virtual scene operator to vary a scene appearance and behavior according to values of the parameters making up a Theme. There are Standard and Custom themes (see section 3.8).
In the LiveAction mode a project’s themes are displayed in the Theme drop-down list of the Project bar (see scetion 3.2.5).
· It is strongly recommended to close all other active applications before switching to the LiveAction mode! It is also recommended to refrain from opening files from the disk during a broadcast session since it causes temporary “freezing” of a frame, which is quite visible if there is some continuous motion in a virtual scene. 
Also note that the application’s interface has specific features in the LiveAction mode:
· clicking the Close button (‘cross’) of a document window does not close but only hide it;

· arrangement of all documents windows and their visibility are saved independently for the Edit and LiveAction modes;

· if HotBars buttons have Hotkeys assigned for them (keyboard shortcut, see section 3.6.3), in the LiveAction mode it is impossible to type symbols corresponding to them in any dialog. That’s why it is recommended to use key combinations with Ctrl or Shift keys for Hotkeys since such combinations are rarely used in text editing fields.
At switching from the LiveAction to the Edit mode (the [image: image31.bmp] button) playback of all video and audio streams is stopped.
3.1.10  Using video streams
As it was mentioned in the Introduction (see section 1), the HotActions application uses 3D scenes created with the help of the 3D Studio Max or Maya graphics editors. After a scene is exported and a project is created, there is an opportunity to use video streams from AVI files in a scene, and what is more important, live video streams from FD300 boards.
Video streams are used as texture maps (or video textures) on any objects of a scene containing Diffuse Map, not necessarily flat ones. Usually for operating a video texture it is convenient to create a simple flat rectangle (Mesh) with an “actor” image to make it visual.
Details of the procedure of assigning a video stream for a texture map are described in section 6 of the 3D scenes creation Guide. After a scene is initialized (see section 3.4.7), its appropriate Diffuse Maps are replaced with live video; the rest maps and parameters of the material are ignored. Video streams are controlled with the help of special commands, which are common for all types of video streams. These commands are described in details in section 7.1 of the Script commands Guide; an example of managing a live video stream and a video stream from AVI file is given in section 8.3.1 of the 3D scenes creation Guide.
The following sections describe in detail all components of the HotActions.

3.2 Main application window
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Fig. 14. Main window of the HotActions application
The main window of the HotActions application (Fig. 14) contains various toolbars and dynamic menus for executing different commands including opening, editing, copying, and saving files.
The background color can be changed. To perform this, place a wanted image BMP file named HotActions.bmp into the folder C:\Program Files\Darim Vision\VS2000 Software\HotActions\ Common\Images. If the window is larger than image from the file, this image is duplicated as many times as necessary to fill up the window.
3.2.1 Toolbars
The HotActions main window includes three toolbars: Standard, General and LiveAction. Their arrangement is managed with the submenu Toolbars of the View menu.
By default the Standard and General toolbars (on the figure below) are docked to the upper border of the main window (Docking View), and the LiveAction bar is hidden.
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Any main window toolbar and also the Properties dialog can be attached to any other convenient place of the window or rendered to the ‘floating’ state with seizing and dragging by their left edge. A double click on a floating toolbar title returns it to the docked state.
The functions executed by the toolbars buttons are listed in the following sections. All buttons have equivalent commands in the corresponding menus in the application main window, they are given in brackets.
3.2.2 Standard toolbar
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(New command of the File menu) creates a new file of a type used in the HotActions;
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(Open command of the File menu) displays a file open dialog;
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(Save command of the File menu) saves changes in the current active document (i.e. whose window is active);
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saves changes in all open windows and corresponding files, except for scene files (*.3d);

[image: image38.bmp]
(Cut command of the Edit menu) moves a selected object of the active document to the clipboard and deletes it from the document;

[image: image39.bmp]
(Copy command of the Edit menu) copies a selected object of the active document to the clipboard;
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(Paste command of the Edit menu) pastes the clipboard contents to the current document.

3.2.3 General toolbar
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(FullScreen Render option of the View menu) switches the Render Output window to the full-screen mode and back;
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(Debug Output option of the View menu) displays and hides the Debug Output window for showing diagnostic, error, and system events messages (section 9.3);
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(Properties option of the View menu) opens the Properties dialog;
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(Update All command of the Tools menu) updates the contents of all open files;
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(Init All command of the Tools menu) initializes a project by executing special Sturtup Actions (see sections 3.1.9; 3.4.4);
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(Stop All command of the Tools menu) stops all Actions performance and clears their queue, stops playback of all animation tracks, video streams, etc. Usually after this command it is necessary to perform Init All command (see above) to restore a project initial state;

[image: image47.bmp]
(LiveAction Mode command of the Tools menu) switches the application to the LiveAction mode (see section 4);
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(Sound Configure... command of the Tools menu) opens the Sound Configure dialog, which is described in detail in an individual document;
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(Options command of the Tools menu) opens the Options dialog (see section 9).

3.2.4 LiveAction toolbar
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The LiveAction toolbar, which is usually attached to the right border of the main window, contains commands of the LiveAction mode control. In this mode the toolbar buttons have the following functions:
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	switches the application from the Edit to the LiveAction mode and back;
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	the Init All command: performs the same operation as the corresponding button on the General toolbar (see section 3.2.3);
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	the Stop All command: performs the same operation as the corresponding button on the General toolbar (see section 3.2.3);
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	Sound Configure command (see section) opens the Sound Configure dialog.


3.2.5 Project bar
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The Project bar, which is attached by default to the upper border of the main window in the LiveAction mode, contains commands for selecting a current project and managing its themes. Elements of the bar are used for the following:
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	Project drop-down list allows selecting a project to be loaded from the frequently used (last opened) ones;

allows opening an arbitrary project;
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	Theme drop-down list allows selecting a current Theme for the active project from the list of themes available for it. In this list names of the Standard type themes begin with an asterisk (see section 3.1.6);
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	opens a currently selected theme window for editing;
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	saves a current theme; if the current theme is Standard, you will be offered to save it as a Custom theme;
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	deletes the current theme; the button is available only for Custom themes.


3.2.6 Menus
The main window includes the File, Edit, View, Tools, Window, and Help menus; many of their commands duplicate main window toolbars buttons described above.
File menu commands allow performing standard operations, such as creating a new file or opening an existing one. This menu also has a list of the most often opened files. The Exit command exits the application.
The Edit menu includes commands of standard editing.
Commands of the View menu allow displaying or hiding toolbars, status bar, Render Output and Debug Output windows.
The Tools menu includes the principal commads of the HotActions application general control.
Commands of the Window menu allow arranging all open working windows in the required order.
The command About HotActions... of the Help menu displays information about the current application version.
According to a window activity, Project, Scene, Action, Hotset submenus appear, and the View menu content changes.
A context menu (Fig. 15) opened by a right click on a free client space of the main window also includes commands of the LiveAction mode control.
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Fig. 15. Context menu of a client space of the main application window
3.3 Editing Actions and their properties
As it was mentioned above, in the HotActions application it is possible to modify virtual scenes with the help of text commands (see section 3.1.3). These commands are referred to as Actions. A special language for creating Actions is described in the Script commands User’s Guide.

Actions can implement whole scenarios performed with the preset sequence automatically, since one Action can invoke execution of others.

Usually an Action is executed after pressing the corresponding button on the Hotbar (see section 3.1.5). We remind that it is possible to drag (or copy/paste) Actions onto Hotbars directly from libraries (see section 3.6.2). Actions are saved in the system as a text document Actions Library (see section 3.1.4).

Action’s properties are displayed in the tabs of the Properties dialog (Fig. 16).

3.3.1 Action tab of the Properties dialog for Actions
Action tab of the Properties window is used for editing the description of an Action and its contents (Body).

It is possible to briefly describe an Action in the Description field; the same description appears in the corresponding field of the Properties dialog for a Hotbar button (see scetion 3.6.3).

The content of an Action is entered into the Body field of the Action tab. Separate commands are located in individual lines (i.e. they are separated by pressing the Enter key). It is possible to enter several commands separated with a semicolon in the same line. It is recommended that all commands strings entered into the Body field start with a colon; this enables the system to automatically prompt tags (words) of a command and its parameters.
Prompts system is adjusted with options of the Auto Editing submenu of the context menu (Fig. 16). This submenu allows enabling/disabling options Context Help (versions of the command word continuation), Colorize Syntax and Tooltips (tips displaying a command’s function at pointing it with a mouse).

The following rules of colorizing syntax and separate command tags are accepted in the application:

· commands parameters are typed as usual black colored text;

· comments are highlighted with green;

· separate command tags are highlighted with blue when their names are identified by the system and the syntax is correct;

· incorrect command tags are automatically highlighted red.

The context menu opened with a right click on the Body field in the Action tab helps to perform standard operations of text editing: copying, pasting, selecting, deleting, etc. Each command of this submenu can be performed by pressing standard for most text editors key combinations on the keyboard.
After an Action command is created or modified, its performance can be tested with the Test button of the Properties dialog (or with the Ctrl+T keys combination).

The Apply button (as well as the Ctrl+S keys combination) simply saves changes without launching the Action. Check the Auto check box so that the changes were saved automatically at losing the focus (for example at clicking an object different from the current Action).
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Fig. 16. Action’s Properties dialog and Body field context menu of Action tab
At debugging the operations performed by the Actions’ commands, it is possible to use command execution messages in the Debug Output window (see section 6). This window in particular receives messages about errors occurring at executing Actions.

3.3.2 Icon tab of the Properties dialog for Actions
In the Icon tab of the Action’s Properties dialog it is possible to select an icon for an Action and assign it with the Set Icon button.

By default the icon is set to a Hotbar button corresponding to the Action from Actions Library (see section 3.6.2). It is possible to reassign an icon for an Action button on Hotbar regardless of an icon assigned in the library. Icons of different Hotbar buttons referring to the same Action from the library can be different (see section 3.6.3).
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Fig. 17. Icon tab of the Properties dialog for Action
The Icons Folder drop-down list presents a list of subfolders with icons that can be assigned for Actions’ buttons. The path to the folder containing these subfolders with icons is specified in default directories of the application (see section 9.2, Fig. 76). By default this directory is C:\Program Files\Darim Vision\VS2000 Software\HotActions\Common\Icons, which is created at installing HotActions. In the Icons Folder subfolders list this root directory for icons is shown as a dot “.”. The <default> item is icons used in the application by default. Selecting the <All Icons> item displays all icons available in all subfolders of the Icons Folder list.
A right click on the window where the icons are shown allows changing their size: they can be either large (32 by 32 pixels) or small (16 by 16 pixels).
3.4 Operations with a 3D scene
3.4.1 Operations with a scene file
Scenes, as well as other files which the application works with, are usually opened at the same time with the whole project. It is also possible to load a scene by a double click on its filename in the project window, or by the Open command of file context menu in the project (see Fig. 48). Names of scenes opened in the project window are in bold type. A scene file is closed either with the Close command of the same context menu or by closing its window with a corresponding system menu.
· If a scene window is a disturbance at work (it covers the main window workspace), it can be hidden by the Hide command from the file context menu of a project (Fig. 48).

To add a new scene to an open project, use the Add File to Group command of the context menu for the Scenes standard group in a project window (Fig. 50). To open a scene file it is also possible to use the Open… command in the File menu of the main HotActions window. In the Open dialog specify the required file extension (“*.3d;*.wrl” or “*.dxf”, see an example on Fig. 12) and select a scene name from the required folder. After this the scene file can be opened faster: with a left click on its name in the local menu Recent Files of the File menu. At opening a scene the application always asks if it should be added to the project if some project is loaded.

To save changes in a scene, choose the Save command in the menu or equivalent button 
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 on the toolbar at scene window active.
The HotActions application does not automatically save the results of scene objects manipulating, i.e. hiding, changing sizes and positions of objects. When a scene has some changes that can be saved, in the title bar of a scene window there is an asterisk “*”. It disappears after the current scene state is saved.
To save a scene under a different name, use the Save As…command.
3.4.2 Symbols for scene objects
During operations with a scene, its name is displayed in the title bar of the scene document window (Fig. 18). The structure of a scene is always presented with a tree of so called Nodes with the following symbols:
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root node of a scene tree
(World), every scene necessarily has one root node;

[image: image67.bmp]
Dummy scene nodes, not displayed in the Render Output window; such nodes are used as auxiliary, for example, for combining real objects into a logical whole, so that it is possible to apply changes for all nodes of this group simultaneously. Note also that a camera in a scene is controlled not directly with a mouse or joystick but by means of such Dummy objects. For this purpose cameras should be associated with separate Dummy objects (see also 3D scenes creation Guide);

[image: image68.bmp]
scene nodes referring to 3D objects (having faces);

[image: image69.bmp]
nodes referring to virtual cameras of a particular scene;

[image: image70.bmp]
nodes referring to light sources of a particular scene.

Objects symbols have additional indications marking presence/absence of tracks (animation):

· small green triangle (like in [image: image71.bmp]) means that a node has its own track in a scene general track;

· small yellow triangle (like in 
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) means that node’s descendants have at least one track of their own in a scene general track.

Operations with tracks are described in the Script commands User’s Guide.

3.4.3 Scene window toolbar and presentation of scene objects according to their types
A scene working window has its own toolbar:

· The [image: image73.bmp] button displays all scene objects as a nodes tree (Fig. 18). The context menu opened by a right click on the required node allows to hide/show it in a scene, copy its name, generate script commands describing current position of the object (see the [image: image74.bmp] button function), or open its properties dialog. A double click on a node selects it for the mouse/joystick manipulation in a scene (see section 5). The selection of a node to be manipulated is saved in a scene file.
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Fig. 18. Working window of scene nodes and a context menu for them
Context menu of this window includes the following commands:

Hide
setting this option hides the node selected in a scene. If the node refers to a light source, it is ‘switched off’;

Reset
restores position and size of the selected scene node as they were at the scene opening. Accordingly, the command is available after changing node’s position and/or size. To show that there are changes, an object name in the scene window is added with an asterisk “*”;

Copy Name
the command copies the selected object name to the clipboard for using, for example, in script commands. To paste an object name copied with this command, use the Paste command of context menu in the Properties dialog at Action editing (see section 3.3.1, Fig. 16);

Copy XForm
equivalent to the [image: image76.bmp] button;

Properties
opens the Properties dialog (section 3.4.5) for the selected object.

· The [image: image77.png]


 button presents all 3D objects of a scene (Meshes , Fig. 19).
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Fig. 19. Representation of all scene meshes and a context menu for them
· The [image: image79.bmp] button presents all cameras available in a scene (Fig. 20).
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Fig. 20. Representation of all scene cameras and a context menu for them
· The [image: image81.bmp] button presents all light sources available in the scene (Fig. 21).
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Fig. 21. Representation of all scene light sources and a context menu for them
· The [image: image83.bmp] button presents all materials available with a scene objects (Fig. 22).
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Fig. 22. Representation of all scene materials and a context menu for them
· The [image: image85.bmp] button allows generating script commands that describe current object position and scale (XForm). After pressing it, script commands resulting in setting the current position and scale of the object are copied to the clipboard. After this it is possible to paste these commands from the clipboard with the Paste command of context menu in the Body field of Properties dialog for Actions. At this, the [image: image86.bmp] (Paste) button in the main application window becomes unavailable, since the toolbar it refers to is used for documents, for a scene in this case, and Paste is not specified for a scene.
· The [image: image87.bmp] button cancels all scene modifications (of scale and positions of all scene objects) and restors the initial state.
· The [image: image88.png]M m P> M



 buttons are used for playing back and stopping a scene track (animation). These buttons are used mostly for previewing animation of a scene loaded as a single file, without a project (i.e. without Actions modifying it, etc.) This is caused by the fact that when a scene is initialized in a project, startup Action commands usually reassign separate tracks control, which excludes them of general scene animation controlled by these buttons.
At any type of scene objects representation, a right click on a free place of the window client area opens a menu (Fig. 23). The menu contains commands of switching the representation type equivalent to the toolbar buttons, and also the View local menu with options of toolbars view.
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Fig. 23. Scene window context menu
3.4.4 HotActions main window menu at work with a scene
At work with a scene, the Scene special menu appears in the HotActions application main window (Fig. 24), and the Edit menu contents change. Commands Play, Stop, Rewind, Reset All Nodes of the Scene menu duplicate the buttons of the scene working window. Commands Copy Name, Copy Xform of the Edit menu duplicate the scene working window buttons described above.

[image: image90.png]©) Hotactions - Sport.3d

Fie | Edt View Scene Tools
[} CopyMame Cukc
(= copyxFom



     [image: image91.png]HotActions - Sport.3d

Fle Edt View | Scene Tools Window Help

PG criep
v stop cies
Revind Culishiftss

Reset AllNodes Clrl+R





Fig. 24. Scene and Edit menus of the main window for a scene
3.4.5 Properties dialog for different types of scene objects
The Properties dialog opened for any scene object (a node, camera, light source, material, etc.) from any presentation (see section 3.4.3) provides detailed information about it.
The information is displayed on the corresponding tabs.

The Node tab displaying a node name, its position, scale, and rotation angles (Fig. 25) looks similar for all objects. These parameters are editable, pressing the Apply button applies the modifications and the Reset button restores a node’s initial state.
Checking the Hide check box hides an object in the scene.
The Control button, as well as a double click on a node in the scene tree (5Fig. 18

 REF _Ref530464242 \h ), selects it for manipulation with the joystick, mouse or array keys. The object’s name at that is in bold type. Operations that can be performed with the joystick are described in section .
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Fig. 25. Node tab of the Properties dialog
For objects of a scene, except for Dummy ones indicated as [image: image93.bmp], the Properties dialog displays additional tabs.
For cameras there is the Camera tab (Fig. 26) allowing the user to specify the FOV (field of view) parameter in degrees or the lens focal distance in millimeters if the Lens option is set. It is also possible to specify the clipping planes parameters and environment parameters range for the selected camera.
The Set Active button renders the camera current in the scene, but does not make it the manipulated object. For this purpose the camera should be selected in the Node tab (Fig. 25) or in the scene objects tree (Fig. 18).
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Fig. 26. Camera tab of the Properties dialog for cameras
For three-dimensional scene objects (Meshes) consisting of sets of faces the additional Mesh tab displays information about number of object’s faces, vertices and the used materials. The Find in Scene button is intended for searching the object in a scene; after pressing it, an object’s mesh starts blinking.

[image: image95.png]Properties

Mesh Name
ideo

[~ Information
Vertces

Faces

Used Materials
VIDED

& Node ) Mesh




Fig. 27. Mesh tab of the Properties dialog
The Light additional tab for scene light sources allows specifying a color for a light source if the On check box is checked. A light source can be ‘turned off’ at all by unchecking this check box. To open the corresponding color selecting dialog, click the Color field. The tab also allows the user to specify the multiplication factor for a light source intensity level in the Multiplier field.
[image: image96.png]Light Name. Tope

Color ¥ on
Multiger: [T

 Node §- Light





Fig. 28. Light tab of the Properties dialog for light sources
For an object selected not from a scene nodes tree (Fig. 18) but from its group (Fig. 19, Fig. 20, Fig. 21, Fig. 22) the Properties dialog displays only the listed above additional properties tabs corresponding to the object type, without the Node tab.
Since materials are not attached to particular nodes of a scene, there are no Node tabs for them. It is possible to see their properties (Fig. 29) after selecting a particular material in the list of all scene materials (Fig. 22). If a material has textures, information about them is also displayed in the properties tab (Fig. 29); texture size, bits per texel (color depth) and number of frames (if more than one) are specified above each texture.

Some of material’s parameters can be modified. Colors of the material are grouped on the left: Ambient color in the shade, Diffuse color of the illuminated surface, Specular color of a flare. On the right there are attributes of the material: its self-luminosity value (Self-Illum.), Opacity and Glossiness.
As well as for the Mesh, the Find in Scene button is intended for searching a material in the scene. After pressing this button the surface which the material is assigned to starts blinking. A second click on this button or switching to another window stops the blinking.
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Fig. 29. Material tab for scene materials
If a scene node or its descendants have an individual track in the scene general track, the Properties dialog contains also the Track tab (Fig. 30).
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Fig. 30. Track tab of the Properties dialog
This tab specifies information about each constituent of an object track. Changes of the object’s position, angle of rotation and scale are displayed in the tab with colored rectangles located on corresponding bars (Fig. 30). The rectangles are colored according to the radio button selected in the Show group.
The Show radio buttons are used for grouping and displaying the following tracks:

· own tracks of an object (Own radio button selected);

· total information about its descendants’ tracks (Sub radio button selected);

· both own tracks of an object and of its descendants (Both radio button selected).

The Properties dialog for the root node of a scene tree (World) represented with the 
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 icon includes the Environment tab.
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Fig. 31. Environment tab of the Properties dialog for the World object
The Ambient Lighting parameters group of this tab page is intended for specifying the color of scene ambient lighting. Click the Color field to open the color selection dialog. The background color, i. e. the color of the space free of scene objects is specified in the same way in the Background group.
The Fog parameters group is intended for using fog effect in a scene. Check the Fog checkbox and specify a required color in the Color field. The Near and Far parameters specify the fog density ratio (in percentage terms) at the near and far clipping planes for a virtual camera. These planes are specified in the Environment Ranges group of parameters of the Camera tab in the Properties dialog for a camera (Fig. 26) and they can vary for different virtual cameras of a scene.
3.4.6 Startup Actions function
After a scene is created in a 3D editor like the 3D Studio Max or Maya and exported, which is described in detail in the User’s Guide on 3D scenes creation, we have a scene file with the *.3d extension.
A scene file can be used in existing projects of the HotActions application or in a new project created specially for it. In any case, it is necessary to have a set of handy tools for managing a scene: for loading a scene, manipulating objects, starting objects’ tracks, etc.
These operations are executed with Actions, which are sequences of one or several text commands. The execution of an Action results in some modification of a virtual scene (see section 3.1.3).
Startup Actions are an important group of Actions. They differ from usual Actions in their task, which is rendering a scene to the initial operating state. Most often such Actions are used after loading a scene.

· One of the Startup Actions advantages is uniformity of operations with projects: it is easy to initialize even an unfamiliar project simply by pressing the 
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 button on the application main window toolbar. Startup Actions are located in a $STARTUP$ folder, since the HotActions application automatically executes the $STARTUP$ folders’ contents after pressing the 
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 button or at switching to the LiveAction operating mode (see section 3.1.9).
· Originally in each Hotset there is a $STARTUP$ folder. By default this folder is hidden, but it can be displayed after switching to the Hotset configuring mode (see section 3.6.6).
Note that the 
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 button becomes available only when a project has at least one Hotset opened. Adding a Hotset to a project and creating a new Hotset are described in sections 3.7.2 and 3.6.1, respectively.
Actions located in the $STARTUP$ folder are executed in a strictly specified top-down order (this refers to the Hotset alternative presentation, see section 3.6.6). Consequently, it is possible to modify the order of execution by moving references to Actions in the folder.
· Note once again that switching to the LiveAction mode (see section 3.1.9) automatically launches all Startup Actions.
3.4.7 Startup Actions creation
The main task of Startup Actions is initializing a project to the initial operating condition. The basic operations required for this purpose are listed below. The commands given as the example belong to the “Init Sport” Startup Action of the “Sport” project available in the software package.
· First of all, load a scene
:DATA.OPEN = «Sport.3d».

· Scene objects can have tracks (animation based on trajectories). In order to control tracks in the virtual studio they have to be named, since for example in the 3D Studio Max application tracks’ names are not specified (see section 2.1.1 of the User’s Guide on 3D scenes creation)
:TRACK.CAM_SPORT.NODE = CAMTRACK.

In other words, this command assigns the name “CAMTRACK” to the “CAM_SPORT” object track; later on this name is used for operations with this track, for example for starting it. Detailed description of tracks control commands is available in section 4 of the Script Commands User’s Guide.
· Create video streams for the scene and assign them for existing materials (these commands are described in details in section 7 of the Script Commands User’s Guide):

//create a video stream connected with the first FD300 board in the system, LIVE_1 in the //Input(s) drop-down list, Fig. 5.
:RENDER.VIDEO.LIVE_1.CREATE = 1

//select the first channel (Line A, see Fig. 5) of the FD300 board
:RENDER.VIDEO.LIVE_1.LINE = A
//specify the video stream format including alpha-channel
:RENDER.VIDEO.LIVE_1.FORMAT = ALPHA

//start the video stream
:RENDER.VIDEO.LIVE_1.START = 1

//assign the video texture from the LIVE_1 video stream to the material named VIDEO so that //the texture is overlaid on all scene objects having this material
:RENDER.MATERIAL.VIDEO.SOURCE = LIVE_1

After loading a scene and naming its tracks Startup Actions as usual Actions can contain any commands for starting them.
For details about any command, see the Script Commands User’s Guide.

3.5 Operations with an Action Library
3.5.1 Operations with a library file
To create a new Action Library file, open the dialog of new files creation with the New command of the File menu in the HotActions application main window or by pressing Ctrl+N keys or the [image: image104.bmp] button on the toolbar. Then select the Action Library type from the list of new file types available. Specify a name for the new library being created and a folder to save it.
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Fig. 32. Selecting a file type and file name at creating an Action Library
To attach the new library being created to the project at once, check the Add to Project checkbox in the bottom part of the dialog (it is checked by default). To open a previously created library, use the file open dialog. Select the Open… command of the HotActions File menu, in the Open dialog specify the Action Library Files type of files to be opened (*.acl, Fig. 12), select the required file and press the Open button. After this the application requests the confirmation for including the file in the current project. If the library is not to be included in the project, for example when it is opened only for copying some of its Actions, press No. After the first opening of the library, it can be opened directly by a click on its name in the Recent Files local menu in the same File menu.
A library can be added to a project with the context menu of the Libraries standard group in the project window.
To save changes in a library, select the Save command of the same File menu or the equivalent 
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 button on the toolbar (at the library window active). To save a library with a different name, use the Save As… command.
3.5.2 Operations with Actions in a library
Actions in a library can be treated like usual files in a folder: they can be copied, pasted, deleted, etc. The same operations can be done with a group of Actions after the required ones are selected as usually – with the arrow keys or mouse clicks and Ctrl or Shift key pressed.
A right click in the library window empty space opens a context menu (Fig. 33). This menu combines some commands of the Action and View menus of the main window (see section 3.5.3).
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Fig. 33. Action Library context menu
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Fig. 34. Context menu of an Action in a library
The Edit command of another context menu (Fig. 34) is used for editing the Body contents of the selected Action. This command activates the corresponding tab of the Properties dialog (Fig. 35). The Properties dialog can also be opened with the Properties command of the context menu of an Action or with the Alt+Enter key combination.
The contents of an Action, or its ‘body’, are a set of script commands, which can be edited in the Body field of the Properties dialog.
After creating an Action or modifying its ‘body’ its commands can be tested; for this purpose press the Test button of the Properties dialog, or use the Ctrl+T key combination.

The Apply button and the Ctrl+S key combination simply save changes in the body without starting the Action. To enable automatic saving of changes made in an Action body at switching the focus from the dialog, e. g. after a click on another object, check the Auto checkbox.
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Fig. 35. Properties dialog for an Action
It is possible to assign an icon to an Action in the Icon page of the Properties dialog. For more details about editing Actions, see section 3.3.
It is possible to exchange Actions between open libraries by drag-and-drop; they can be copied or moved (with the Ctrl key pressed at dragging).
When Actions are moved, the corresponding buttons are added to a Hotbar. If they are moved to an empty space on the Hotset, a new Hotbar is created (see section 3.6.2).
3.5.3 Main window menu at work with an Actions Library
At work with a library, a special Action menu for manipulating a library’s contents is added to the standard list of menus of the main window; the View menu is modified (Fig. 36).
[image: image110.jpg]Action Tools  Window
New

Rename F2
Edt

Delets  Ctri+Del




 
[image: image111.png]View Action Tools Window Help.
Fullscreen Render

Toabars »
v Status Bar

Large Icons
Smalllcons
Lt

* Detalls

Auto Arrange

© Render Window  Ciri4)
v Debug Output  Crkeshit+0

Properties. Alt+Enter





Fig. 36. Action and View main window menus
The Action menu includes the following commands:

· New – creates a new Action;
· Rename – renames an existing Action;
· Edit – opens the Action Properties dialog for editing the ‘body’ of an Action;
· Delete – deletes the selected Action.

The View menu includes the following commands for work with Action Libraries:

· Large Icons, Small Icons, List, and Details options change the presentation of Actions in a library window to large icons, small icons, simple list or detailed list (with several columns), respectively;

· Auto Arrange option enables automatic Actions arrangement in rows in the library window (if the Large Icons or Small Icons mode is selected);

· Line up command arranges Actions in rows in the library window (if the Large Icons or Small Icons mode is selected).

Actions in a library can also be managed with the library context menu (Fig. 33).

3.6 Operations with Hotsets and HotBars
HotBars’ and Hotsets’ functions are described in section 3.1.5.
3.6.1 Operations with a Hotset file
Hotsets are created and opened similar to other documents which the HotActions works with.
To create a new Hotset, open a new files creation dialog with the New command in the File menu of the application main window or with the Ctrl+N key combination or the [image: image112.bmp] button on the toolbar. Select the Hotset Panel type from the list of available file types. Then specify the file name and the folder to save it in.
[image: image113.png]File ype

Tope Descrption
v et VS PrctFle
ectnlivay S Actonliray Fie
Hotot Panel VS Halse Fie
ElTetbocument  TatFie

Logaton
DveRmSesen  |G)

% Add to Proect ok Cancel





Fig. 37. New dialog for specifying file type and name at Hotset creating
If the new Hotset should be attached to a project, check the Add to Project checkbox in the bottom part of the dialog (it is checked by default).

As all other files included in a project, Hotsets are usually opened at once at opening a project. Unlike other file types, Hotsets are rarely used as independent files, mostly they belong to projects, for which they are, in fact, created.
A Hotset can be opened without a project too; it is performed with the Open command of the File menu (Fig. 12). At this the application requests whether the Hotset should be added to the project, if there is one loaded. After an existing Hotset is opened for the first time or a new one is saved, it can be fast opened directly by a click on its name in the Recent Files local menu of the File menu.
For adding a previously created Hotset to the opened project, use the context menu for the Hotsets standard group in the project window (Fig. 50).
A Hotset can be saved with a different name by the Save As… command in the File menu. The 
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 button or the Save command save it with the same name (at the Hotset window active).
3.6.2 Manipulating HotBars and their buttons in a Hotset
In the Edit mode (see section 3.1.9) of the control environment the arrangement of HotBars in a Hotset can be changed, and it is possible to add and modify buttons immediately on a HotBar.
It is possible to add buttons to any HotBar by dragging Actions from Action Libraries directly on it. When Actions are placed on a Hotset empty space, a new HotBar is created for them.
Buttons can be easily manipulated, it is possible to:

· change their text, icons, assign Hotkeys (keyboard shortcuts) with the Properties dialog for buttons (Fig. 39);

· delete, add, copy buttons, insert separators between them with the context menu (Fig. 38);
· change their order on a HotBar by dragging and dropping;

· drag them between various HotBars and Hotsets.

In the Edit mode a single click on a button selects it but not presses. To test a button effect, click it with the Alt key pressed. The Test command of the button context menu is intended for the same (Fig. 38). Other specific for buttons commands of this menu are the Insert Separator and Take&Set Snapshot (for setting a scene image onto a button, see section 3.6.4). The rest commands of the context menu are intended for standard operations with buttons: copying (Copy), deletion (Delete), etc. The Properties command opens the Properties dialog, which serves for editing button properties (see the following section).
Note that each command of this menu has a Hotkey.
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Fig. 38. Button context menu
Hotbars themselves can be moved between Hotsets with the mouse.
· Note once again that a Hotset does not contain properly Actions; it contains only references to particular Action Libraries. At the opening of a Hotset, the application automatically loads Actions which its buttons refer to from the corresponding libraries. That is why a Hotset is independent of a particular description of a certain Action. Thus, a Hotset can be formed reasoning from the subject of the future TV show.
3.6.3 Operations with HotBar buttons properties
The Properties dialog allows the user to modify buttons’ properties (Fig. 39). The dialog can be opened by the Properties command of the context menu (Fig. 38) or by the Alt+Enter key combination.
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Fig. 39. Properties dialog for buttons
The Button Name field of the first page of the Properties dialog is intended for editing a button name. A button description displayed in the Description field is imported from the corresponding Action and therefore it is not editable. The Action that a button refers to can be changed in the Target Action drop-down list; the library from where Actions are selected is specified in the Target Library drop-down list. If a library is changed, its Actions become available in the Target Action drop-down list.
The Radio Group drop-down list is intended for specifying a radio group for the current button. It is possible to select a radio group from available groups in the list or to create a new group by entering its name in any place of the list. A radio group is a set of buttons in which only one button can be pressed at a time.
The Apply button of the Properties dialog saves all changes without exiting the dialog.
The Hotkey page of the dialog allows the user to assign a Hotkey (keyboard shortcut) for a button.
· Note that in the LiveAction mode the characters corresponding to Hotkeys cannot be entered in any of the dialogs. So it is recommended to use key combinations with Ctrl or Shift keys at assigning Hotkeys, since these combinations are rarely used in text editing fields.
An icon for a button can be changed in the Icon tab page. It is completely identical with the Icon tab page of the Properties dialog for Actions themselves (see section 3.3.2), but it specifies an icon for a button, not an Action. Icons of different buttons referring to the same Action may differ. At the Snapshots option enabled in the properties of the HotBar containing the button (Fig. 42), icons are replaced with snapshots – images copied from the Render Output window. For more details about operations with snapshots, see section 3.6.4.
The body and description of an Action corresponding to a button are displayed in the Action tab page (see section 3.3.1). The changes made in this page are immediately reflected in the source text. In the same way, the changes made in an Action body in a library immediately change the properties of the corresponding button.
The full synchronization of bodies of Actions in libraries and all Hotbar buttons is performed with the Update All command of the Tools menu of the application main window. The 
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 button on the General toolbar of the application main window executes the same operation (see section 3.2.3).
3.6.4 Using Snapshots for HotBar buttons
It was already mentioned that when the Snapshots option is enabled in a HotBar properties (see section 3.6.5) icons of all its buttons are replaced with snapshots – images captured from the Render Output window.
The easiest way to use the opportunity of placing a scene image on a button is selecting the Take&Set Snapshot command from the context menu for buttons (Fig. 38). Note that on Fig. 38 this option is unavailable since usual icons are used in this HotBar (so remember to switch the HotBar to the Snapshots mode first). In the dialog opened by this command it is necessary only to specify a name for the image file, which usually coincides with the name of a button it is intended for, and a folder to save this file, which is most often the Shots folder in the project local directory. If this folder is absent, the application requests a confirmation for creating it.
The Icon tab page of the Properties dialog for a button is modified correspondingly when Snapshots are used (Fig. 40). The control elements of this page allow for selection of a folder with images.
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Fig. 40. Icon tab of the Properties dialog for a button
The Icons Folder drop-down list is used for specifying the folder from which images for buttons are selected. All BMP files in the specified folder become available for selection (they are automatically scaled by the application if necessary). A “.” dot in the list stands for the project folder, the <default> folder contains the default icons.
The buttons located directly on the right of the folders drop-down list are intended for adding folders to the list and removing them. If the Add Subpaths option is enabled at adding a folder, all its subfolders are also added to this list. If the <All Icons> is selected, it is possible to choose an icon from all folders of the list.
To assign a selected image for a button, it is sufficient to double-click it or press the Set Shot button. The Take Shot button captures the current image from the Render Output window and adds it to the current folder for snapshots (selecting the <All Icons> in the folders list makes this button unavailable).
· Note that the Delete button deletes a selected image from the disk.
3.6.5 Context menu and Properties dialog for HotBars in a Hotset
The context menu of a Hotset’ includes the main commands of manipulating HotBars. These commands duplicate the commands of the HotBar menu of the application main window (see section 3.6.7), except for the Properties command available.
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Fig. 41. Context menu for HotBars in a Hotset
The Properties dialog for any HotBar in a Hotset (Fig. 42) allows the user to change its name, description and representation of buttons on it (text arrangement and icons size). In particular, it is possible to change the arrangement of text on buttons: At Bottom, At Right, or None. Selection of the Snapshots option enables using snapshots – images captured from the Render Output window – instead of icons for all buttons of a HotBar (see section 3.6.4 for information about operations with snapshots). After pressing the Apply button for saving changes, the application requests whether it is necessary to create a dedicated folder (if absent) for snapshots named Shots in the current project folder. For details about operations with buttons, see section 3.6.2.
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Fig. 42. Properties dialog for a Hotbar
3.6.6 Alternative document-like Hotset presentation
You can use an alternative document-like presentation of a Hotset for configuring.
This document includes one or several folders corresponding to Hotbars (Fig. 44). To render a Hotset to this presentation, double-click it on an empty space or enable the Configure option in the Hotset context menu (Fig. 43).
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Fig. 43. Hotset context menu
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Fig. 44. Hotset document-like presentation and a context menu for references
For distinguishing windows of different presentation of a Hotset when both windows are minimized, their titles are indicated in addition with ‘1’ and ‘2’ numbers after the colon.
All folders are displayed in the left part of the document window, and the contents of a selected folder are in the right part.
At creating a new folder in this presentation of a Hotset, a Hotbar with the same name is created automatically. A particular Hotbar can be shown/hidden by checking/unchecking the corresponding folder of the Hotset.
The contents of folders are references to Actions corresponding to Hotbar buttons. The order of references correlates with the order of buttons. It is possible to add references to folders (and buttons to Hotbars) by dragging Actions from an open library, references from other folders, or buttons from other Hotbars.
References are manipulated in the same way as buttons: with the context menu that can be opened by a right click on a reference (Fig. 44). For instance, a separator between buttons of a Hotbar floating window can be added by the Insert button or the Insert Separator command of the context menu. The same command is available in the context menu for a button (Fig. 38). A separator is added before the selected reference (button) and it can be deleted with the Ctrl + Del keys or Delete command of the same menu.
References to the Actions that are executed at each scene initialization are located in the $STARTUP$ folder available in every Hotset. Usually the Startup Action is placed into this folder, and the Hotbar corresponding to the folder is hidden. See section 3.4.6 about Startup Actions.
3.6.7 Main window menu at operations with a Hotset
The Hotset special menu is added to the application main window at work with a Hotset (Fig. 45). This menu is identical with a Hotset’s context menu and includes the following commands:

· New Hotbar – creates a new Hotbar.

· Fit Hotbars – modifies a Hotset’s proportions so that all Hotbars can be entirely visible. This doesn’t influence Hotbars overlapping. The command is available at the Auto-Fit option disabled since it is its one-time equivalent.
· Auto-Fit – enables automatic Hotset sizes control. All Hotbars are always entirely visible, save for their overlapping areas.
· Open All Source Libraries – opens all Action Libraries referred to in the Hotset.

· Background Color… – opens the dialog of selecting a color of the Hotset workspace (the background for placing Hotbars on it).

· Configure – opens a document-like Hotset presentation including one or several folders corresponding with Hotbars (see section 3.6.6). This can also be done with a double click on an empty space in the Hotset.
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Fig. 45. Hotset and Hotbar menus of the application main window
Besides, the HotBar menu (Fig. 45) appears in the application main window; it includes the following commands of HotBars control:

· Cut – sends the selected HotBar to the clipboard;
· Copy – copies the selected HotBar to the clipboard;
· Paste – pastes the selected HotBar from the clipboard to the Hotset; this command is available when in the clipboard there is a HotBar after one of the previous commands;
· Delete – deletes the selected HotBar.
The commands of this menu are identical with commands of the HotBar context menu.
3.7 Operations with a Project
3.7.1 Operations with a project file
The HotActions application works with only one project at the same time. At attempt to open another project, the application requests whether changes in the current project should be saved, closes it and then opens another one.
Existing projects are opened from the File menu of the application main window. Select the Open Project… command and in the system Open dialog (Fig. 12) specify the path to the required project or select it from its folder. After a project has been opened once, its name is added to the local menu of the Recent Project command and it can be opened from this menu.
New projects as the other files manipulated in the application can be created in the dialog that is opened with the New command of the File menu (Fig. 47), Ctrl+N key combination or the [image: image125.bmp] button on the window toolbar. In this dialog select the VS Project in the File type field (Fig. 46), specify a new project name and a folder to save it.
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Fig. 46. Dialog of specifying a new file type and name at a Project creation
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Fig. 47. File menu of the main window for operations with a project
· An opened project can be saved with the File menu. When there is a project opened, the File menu is extended with the Save Project and Save Project As… commands as well as the Close Project command (Fig. 47). Besides, the [image: image128.bmp] button can be used for saving a project if its window is active. If a project file is moved, for example to another folder, without the HotActions, references to all files included in it become invalid and you will have to specify again the path for each file at its opening. For moving a project with paths to its files, use the Save Project As… command, at this all references to files are updated automatically and the files themselves remain on their locations. Another way is to save all files of a project in its local folder and move this whole folder with all its contents.
· The Pack Project for HA Lite… menu command allows the user to transform a project for work in the Hot Actions Lite application. 

3.7.2 Working with files and file groups in a project
For general information about work with files in the HotActions application, see section 3.1.7.

Usually all files included in a project are opened at once when the project is opened. Any file of a document can also be loaded by a double click on its name in a project window or with the Open command of the project context menu (Fig. 48). Names of the loaded files in a project window are in bold type.
The Close command of the context menu closes a file, the Hide command hides a document’s window, and the Remove command deletes a file from a project. The Properties option displays a file properties dialog (Fig. 51).
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Fig. 48. File context menu in a project window
The application suggests the user to add any file to the project (except for a project file) at its opening if there is a project loaded and the file is not included in it.
To add a file of a type which the HotActions works with to an opened project, use the Add File to Group command of the corresponding group context menu in the project window (Fig. 50). For opening a file you can also use the Open… command of the application main window File menu. Specify a required file name in the Open dialog. After this the file can be opened faster, directly with a click on its name in the Recent Files local menu of the File menu.
A window of each project includes Standard Groups – individual folders for files of each standard file type which the HotActions application works with:

· Scenes group for scenes (files extension is *.3d);

· Hotsets group for Hotsets (files extension is *.hot);

· Libraries group for Action Libraries (files extension is *.acl).

The HotActions application also supports standard operations with simple text documents (*.txt files). When a text document is added or created, the Texts standard group appears in a project. A special group can be created for any file type, as described below.
When files are added to a project, they are automatically distributed among proper groups. At attempt to add a file to a standard group of a different type, it still comes to the group of files of its type.
Standard groups for files operated in the HotActions cannot be removed or renamed unlike Custom Groups that can be created with the context menu (Fig. 49) opened with a right click on a project window empty space. Any Custom Group can contain references to files of different types at the same time.
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Fig. 49. Project context menu
The Open All Files and Close All Files commands of the context menu open and close respectively all files included in a project.

The Unhide All Files and Hide All Files commands show/hide document windows of all files included in a project.
The New Theme... command creates a new Theme for a project. In the dialog that appears at selecting this command, it is possible to specify a new theme name and type. For details about themes, see section 3.1.6.

The New Custom Group... command creates a new custom group. In the dialog that appears at selecting this command, it is possible to specify a new group name or accept the default name suggested by the application.
The Add File to Project command adds to the opened project a file of one of the types supported by the application. It is necessary to specify the file path in the dialog opened by this command. The Properties command opens the Properties dialog for the last selected group (Fig. 51).

A right click on a group opens its context menu (Fig. 50) for operations with groups:

· Open Group and Close Group commands open and close all files included in the group.

· If working windows of project files give the trouble of overlapping the workspace of the application main window, they can be hidden with the help of the commands described below.
· The Hide Group and Unhide Group commands hide/show respectively windows of all documents included in the group;

· the Delete Group and Rename… commands delete and rename respectively the selected group if it is Custom;

· the Properties command opens the Properties dialog for a group (Fig. 51).
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Fig. 50. Example of an open project window and a context menu for groups
In the File tab page (Fig. 51, on the left) of the Properties dialog for a custom group this group can be renamed. It is also possible to change a description of any group or file in this dialog. Additionally the Properties dialog displays full paths of files and their paths relative to a project file.
The Directories tab page is used for specifying additional file search paths for the current project. This tab relates to the whole project and it is the same for files and groups (Fig. 51, on the right).
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Fig. 51. File and Directories tabs of the Properties dialog for groups
If a file specified in a project is not found (for example if it was moved or deleted), the application searches it using the following paths:

· in the current project folder, i. e. where the project file is located;
· in the folders specified as additional for particular file types in the project (Fig. 51, on the right);
· in the folders specified in the application settings, in the Default Directories tab page of the Options dialog (see section 9.2), where full paths are specified for each file type. These paths are identical for all projects, that is to say they are ‘system’ paths.
If a file is not found in any of the specified locations, the application displays an error message, like the one on Fig. 52.
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Fig. 52. File not found message
The Yes button opens the dialog for specifying another path. The new path is automatically added to the list of the current project additional paths and it will be saved with this list.
3.7.3 Main window menu at work with a project
At work with a project, the application main window menu is extended with the Project menu (Fig. 53).
Commands of this menu duplicate the ones of the project context menu (Fig. 49).
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Fig. 53. Main window Project menu for operations with a project
3.8 Operations with a Theme
A Theme is a description of a project’s variables (parameters) used in its Actions (see section 3.1.6).

3.8.1 Operations with a Theme file
A new Theme is created with the New Theme command of a project context menu (which is opened with a right click on a project window empty space, Fig. 49) or of the main window Project menu at work with a project (Fig. 53).
Specify a name for the new theme in the Theme name field of the dialog (Fig. 54):
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Fig. 54. New Theme creation dialog
A new theme type is specified in the Location group.

The differences between Standard, Custom and Other theme types are described in section 3.1.6. Standard and Custom themes differ in that in the LiveAction mode only Custom themes can be edited and saved. In the Theme drop-down list on the Project toolbar (see 3.2.5) names of Standard themes start with an asterisk (*). Other themes belong to the Custom type as well but these files can be created in an arbitrary folder. When creating a theme of this type, the button of selecting a folder for saving it becomes available. If this theme is added to a project, the specified path is added to the Others field in the additional search paths of the current project (Fig. 51).
All themes of a project are available for selection in the LiveAction mode (see 3.1.9). Only one theme can be loaded (opened) in a project. If it is not specified explicitly, the application loads the default theme (Default in the Theme drop-down list, see section 3.2.5) that is the last saved or the last selected one.
At adding a theme to an opened project, use the context menu for the Themes standard group in a project window if there is one.
A previously created theme always can be opened with a system file open dialog. To perform this, select the Open… command in the File menu of the HotActions window, specify the Theme files (*.vst) file type in the Open dialog (Fig. 12), select the required file, and press the Open button.
After these operations the application displays a confirmation request for loading the file in the current project. If you want to open a theme without loading it into the project, for example for copying some variables from it, press No.

After a theme is opened once, like any other file it can be opened faster with the Recent Files submenu of the same File menu.
To save changes in a theme, select (at the theme window active) the Save command of the same File menu or press the equivalent to this command 
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 button on the Project toolbar (see 3.2.5). The same operation is performed with the Ctrl+S key combination. To save a theme with a different name, use the Save As… command. If the current theme belongs to the Standard type, the user is offered to save it as a Custom theme. A Custom theme can be deleted with the [image: image138.jpg]


 button on the same toolbar.
3.8.2 Operations with theme variables
As it was described in section 3.1.6, if there is a name of variable from the loaded theme in an Action commands, this name is replaced with the variable’s value at the Action start (this is the so-called macro substitution).
A right click on a theme window empty space opens the context menu (Fig. 55). The New Variable item of this menu is used for creating new variables.
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Fig. 55. Context menu of a theme document
At work with a theme document, the application main window menu is extended with the Variable menu (Fig. 56).
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Fig. 56. Variable menu of the application main window at work with theme variables
The context menu of a variable is the following:

[image: image141.jpg]cut ek
Copy  ChleC
Delste  Ctrl+Del

Rename F2
Edt R4

© Properties Alt+Enter




Fig. 57. Theme variable context menu
Right after a new variable is created, it is necessary to specify its properties (particularly its type and value by default). The Properties dialog (example on Fig. 58 for a numerical variable) can be opened with the Properties command of the context menu or with the Alt+Enter key combination.
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Fig. 58. Properties dialog for a numerical variable
An important property of a variable is its type specified with the Type drop-down list of the variable properties dialog (Fig. 59).
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Fig. 59. Type drop-down list of a theme variable Properties dialog
There are the following types of variables:

· STRING – string value. Newly created variables belong to this type by default;

· NUMBER – numerical value;

· COLOR – chromatic variable;

· FILE – file name variable, with the possible extensions mask;

· VARIANT – this variable allows the user to select from a set of predefined values (of the ‘string’ type).

According to the selected variable type, the properties tab page modifies its appearance and functionality. For example, for the COLOR type variable the Properties dialog looks like the one on Fig. 60. A click on the Value color field of this dialog (Fig. 60) opens a standard color selection dialog.
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Fig. 60. Properties dialog for a variable of the COLOR type
A value of the FILE type variable is selected in the Open dialog (opened with the [image: image145.png]


 button) by the mask specified in the File Extensions field of the Properties dialog (Fig. 61). The possible file extensions are separated with a comma or a space.
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Fig. 61. Selecting a value for the FILE type variable
The possible (alternative) values of the VARIANT type variable are separated with line feeds (Enter); any value may be initially specified in the Value field.
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Fig. 62. Editing a variable of the VARIANT type
A variable description is given in the Description field of the Properties dialog. When the description is specified, it is displayed in the document window on the right of the variable name.
The Apply button of the Properties dialog (Fig. 58) saves changes of variable’s properties.
The Edit command of the context menu (Fig. 57) is used for editing a variable value. A double click on a variable is equivalent to this command. The dialog for value editing depends on a variable type. Standard file open and color select dialogs, respectively, are used for the FILE and COLOR types of variables; a dialog with a drop-down list of possible values is used for variables of the VARIANT type (Fig. 63).
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Fig. 63. Editing the value of a variable of the VARIANT type
· Note that in the LiveAction mode the editing of any theme variable value is possible only with the dialog opened by a double click on the variable name in the theme document window.
3.9 Operations with text documents
The HotActions application supports standard operations with simple text documents. This feature may be useful for description of work with a particular project and various comments.
As files of other types processed in the application, text documents (files with the *.txt extension) can be opened automatically as belonging to a project or independently. At adding or creating a text document, the Texts standard group appears in the project (see section 3.7.2).
To open a file individually (not as a part of a project), select the Open… command in the File menu, and in the Open dialog (Fig. 12) select the file name from the required folder having set the *.txt extension in the file types drop-down list. After this procedure the file will be available for fast access from the Recent Files local menu of the File menu. When opening a file, the application always asks whether it should be added to a project, if there is one loaded.
To save changes in a file, select the Save command of the File menu or press the equivalent 
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 button on the toolbar (at the text document window active). To save a file with a different name, different extension, different location, etc. use the Save As… command.
A new text document is created by selecting the Text Document in the New dialog opened by the New command of the File menu in the application main window or by the Ctrl+N key combination.
4 Managing the application modes of operation
As it was mentioned above (see section 3.1.9), the application has two modes of operation: Edit and LiveAction.

The application is switched to the LiveAction mode by pressing the Start LiveAction [image: image150.bmp] button on the LiveAction toolbar of the main window (see section 3.2.4) or its equivalent on the General toolbar (see section 3.2.3). The button icon changes to 
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. A second click on the button switches the application back to the Edit mode.
At switching to the LiveAction mode the main working window is rendered to the Fullscreen mode by default, and the second monitor displays a scene image if there is one loaded. If in the C:\Program Files\Darim Vision\VS2000 Software\HotActions\Common\Images folder there is a *.bmp file named LoadingProgress.bmp, its image is displayed on the output monitor before loading a scene. The same image is displayed in the Render Output window (section 7) at projects reload.
If there is no scene previously loaded in the HotActions, the monitor displays a black image. If the C:\Program Files\Darim Vision\VS2000 Software\HotActions\Common\Images folder contains a BMP file named EmptyRender.bmp, it is displayed on the monitor instead of the black image. The same image is displayed in the Render Output window at starting the application.
The settings of switching to the LiveAction mode can be changed in the Options dialog (see section 9.1). A click on the window closing button (a cross in the top right corner) in the LiveAction mode doesn’t close a document (file), but only hides its window.
The Ctrl+Alt+Shift+Home and Ctrl+Alt+Shift+End key combinations are also used for switching to the LiveAction mode and back. These combinations can be convenient in a one-monitor configuration.
The context menu that is opened with a right click on an empty client area of the main window also includes commands of the LiveAction mode control. These commands as well as the rest buttons of the main window toolbars are described in section 3.2. Having tried these widgets, the user can choose the most convenient for him.
The Render Output window can be switched to the Fullscreen mode and back with the 
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 button of the General toolbar (see section 3.2.3) or with the Ctrl+Shift+F key combination. This operation does not imply switching the application to the LiveAction mode. Switching to the Fullscreen mode is performed also with the Ctrl+Shift+Home key combination, switching back – the Ctrl+Shift+End combination. See section 9.1 for information about settings of the Fullscreen mode for the Render Output window.
5 Using joystick and mouse for managing objects
Scene objects can be managed (dynamically rotated and scaled) with the mouse, joystick and keyboard.

5.1 Manipulation object selection
Usually after a scene is opened (for example as a part of a project) the object (node) selected for manipulating by default is the scene node named “ALL”. It is possible to select any other object for manipulating, for example, a camera by a double click on it in the scene nodes window (Fig. 18).
The name of the node selected for manipulation is in bold type in the scene window. There is a special system name <CURRENT> for use in script commands; this name always specifies the currently selected node. All commands addressed to the <CURRENT> object are executed to the object selected at the moment.
It is possible to enlarge the variety of operations that can be performed on a selected object with additional keys of the keyboard:

Tab
cyclic switching from one axis to another at rotation/movement/scaling;

+ (plus)
increasing the speed of an object movement beginning with zero value (position of rest);

– (minus)

decreasing the speed of an object movement (for an object moving in the positive direction of the movement axis) or increasing the speed if the object is moving in the negative direction of the selected axis or is not moving; position of rest is zero value;

Space
stops an object movement, sets the movement speed equal to zero;

Ctrl+R
restores an object to the initial state (as the one after the scene is loaded).

Modifiers:

Ctrl
an object is scaled along the current axis on a mouse or joystick gesture or arrow keystroke;

Alt
an object is moved along the current axis in the scene area.

If a selected object is a Camera, the following keys are also used (see the description of the Camera tab page of the Properties dialog for a camera in a scene, section 3.4.5):

Home
set a camera focal distance (Zoom) to the default position;

PgUp / PgDown
increase/decrease the focal distance. The Mouse Wheel rotation performs the same operation.
A camera of the Target type controlled with the joystick should be managed not directly but through auxiliary Dummy nodes with which the camera should be connected at the scene creation in the 3D Studio Max (see the User’s Guide on 3D scenes creation).
Objects can be manipulated also in the Node tab page of the Properties dialog (see section 3.4.5).
5.2 Joystick initialization
To use a joystick, it is necessary to include a special Action named Init Joystick from the Joystick.acl standard library in the $STARTUP$ of a Hotset (see section 3.4.6). For this purpose, it is recommended to add this library to the project first (instructions for this operation are in section 3.5.1). This library is intended specially for work with the joystick and is located by default in the \Common\ActLibs folder relative to the folder of the HotActions.exe application (the C:\Program Files\Darim Vision\VS2000 Software\HotActions\Common\ActLibs folder if the virtual studio is installed on the C drive as usually).
Another way to initialize the joystick is direct inclusion of joystick initialization commands copied from the same Action named Init Joystick of the Joystick.acl standard library in the Startup Action for a particular scene.
Joystick sensitivity by axes and responses for pressing/releasing/holding particular buttons are specified in the joystick initialization commands. Note that in the Init Joystick Action the object for manipulation is always the current selected node in the scene, since all commands refer to the node named <CURRENT>. For descriptions of specific commands see the Script Commands User’s Guide, which is another document enclosed with the software package.
· The two foregoing ways of the joystick initialization can be effectively combined as follows: the Init Joystick Action initializing the joystick on the whole should be included in the $STARTUP$ folder of a Hotset; and only the commands specifying the joystick sensitivity should be added to the Action initializing a particular scene. In this case make sure that the Startup Action of a particular scene FOLLOWS the Init Joystick Action in the $STARTUP$ folder (information about the order of Actions execution is available in section 3.4.6). This order is necessary so that the commands specifying the joystick sensitivity are executed after the joystick initialization. The method described is convenient for specifying different joystick sensitivity for different scenes, which may be required for example because of the difference in scenes scaling units.
6 Debug Output window
In the HotActions application there is an opportunity to track diagnostic, error and warning messages, the course of script commands executing and other events. The Debug Output window is used for this purpose. It can be opened by enabling the Debug Output option of the View menu or by pressing the Ctrl+Shift+0 key combination. Besides, you can use the 
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 button on the General toolbar (see section 3.2.3) of the application main window:
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Fig. 64. Debug Output button on the toolbar
The type of messages displayed in the Debug Output window can be specified in the Options dialog of the application general settings that is opened by the Options… command of the Tools menu or by pressing the F10 button in the Debug Output tab page. See section 9.3 for more detailed information about the settings of this tab pane. Whether the Debug Output window be opened or closed, messages of all selected types are registered in a log file, the name of which is specified in the application general settings (see section 9.3). This file can be sent to the developers with the purpose of receiving technical support if necessary.

By default the Debug Output window is docked to the left bottom edge of the application main window (Docking View). This window can also be displayed in any part of the main window. It can be achieved by dragging it at the left bound keeping the Ctrl key pressed, by pressing the [image: image155.bmp] button  in the left top corner of the window, or by switching off the Docking View command in the context menu (Fig. 65). To dock the Debug Output window back to a border of the application main window, drag it to this border and double-click it, or enable the Docking View option in the context menu of the window title bar.
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Fig. 65. Debug Output window title bar context menu
The Enable Docking option should be enabled in this context menu to make the docking of the window possible. The Hide command or pressing the [image: image157.bmp] button hides the window.

The commands of the Debug Output window context menu (Fig. 66) allow performing the following operations:
Show Columns
 Sending Time
show the column of message receiving time; time is counted from the start of the application session in the “hours : minutes : seconds : milliseconds” format (the Time column);

Module Name
show the column with the name of a virtual studio software component a message from which is received in the Debug Output window (the Module column);

Copy
(Ctrl+C key combination) copy the lines selected in the window to the clipboard, later these lines can be inserted from the clipboard to any text application, for example to the Notepad or an e-mail message.

The lines are selected by common operations: with the help of the left mouse button and the Ctrl or Shift keys (as usually at work with files in Windows). The Ctrl+A key combination is used for selecting all messages in the window;

Clear
delete all messages from the window.

The icons displayed in the Message column on the left to the text ([image: image158.png]


, [image: image159.png]


, [image: image160.png]


, etc.) indicate the type of a message: information about uploaded data and modules, error message, command execution message, etc. For more details about messages types, see section 9.3.
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Fig. 66. Debug Output window context menu
7 Render Output window
The Render Output window is intended for displaying the results of the studio operation (the synthesized 3D graphics image with realtime video streams). At working with the studio this window is usually displayed on an auxiliary display device (second monitor), on which the desktop is extended (section 2.2). The graphics processor should provide the necessary performance when displaying a 3D scene. At switching to the LiveAction mode the Render Output window is rendered fullscreen on the second monitor.

The Render Output window can be switched to the Fullscreen mode and back with the 
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 button on the General toolbar (see section 3.2.3) or the Ctrl+Shift+F key combination. This operation doesn’t imply the switching of the entire application to the LiveAction mode. Switching to the Fullscreen mode is also performed by the Ctrl+Shift+Home key combination, and switching back by the Ctrl+Shift+End key combination.
7.1 Commands of the application main window menus for working with the Render Output  window
The Center Render Window command of the Window menu of the HotActions main window (Fig. 67) places the Render Output window into the centre of the application window. Mostly it is necessary at switching to the one-monitor configuration or at changing the relative position of the main and the additional monitors.

The FullScreen Render command of the View menu switches the Render Output window to the fullscreen mode and back. The Render Window command of the View menu (Fig. 67, on the right) closes the Render Output window or opens it if closed.
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Fig. 67. Window and View menus of the application main window
7.2 Menu commands of the Render Output window
The Render Output window also has its own menus. The View menu (Fig. 68) of the Render Output window contains the following commands:

· Frame Rate displays the information about the window size and some average statistical information about the studio performance for the currently displayed scene: the minimal time of calculation and displaying of one of the last four frames (in milliseconds);

· standard window sizes (320х240, 640х480 and 768х576) that can also be set by the corresponding key combination (Alt+1, Alt+2, Alt+3);

· Fullscreen (Ctrl+Shift+Home) allows switching to the fullscreen mode. At that the entire application is not switched to the LiveAction mode. Switching to the Fullscreen mode is also performed by the Ctrl+Shift+Home key combination or by the 
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 button of the General toolbar (see section 3.2.3). Switching back is performed by the Ctrl+Shift+End key combination.
The Engine (F8) command of the Options menu (Fig. 68, right) opens the dialog with the information about the displaying program module that is used in the virtual studio (Fig. 70). The Render (F11) command opens the Render Options dialog with the information about settings of the displaying module (Fig. 71). Both dialogues are described in the next section.
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Fig. 68. View and Options menus of the Render Output window
With the help of the Tools menu commands (Fig. 69) the current image of the Render Output window can be printed (Print…) or saved to a BMP file (Take Snapshot… or Ctrl+Shift+S).
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Fig. 69. Tools menu of the Render Output window
8 Dialogs of display settings
· It is not recommended to change the settings of the dialogs described below without special instructions of the technical support service. These settings are described for general examination.

The Select Render Engine dialog displays the information about the name, version and the path to the displaying program module used (Fig. 70). It is opened by pressing the F8 key on the keyboard or by the Engine command of the Options menu in the Render Output window (Fig. 68). This information can be necessary for the developers and the technical support service.
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Fig. 70. Select Render Engine dialog
The Render Options dialog (Fig. 71) contains the information about the settings of the image displaying module in the virtual studio. It is opened by pressing the F11 key on the keyboard or by the Render command of the Options menu in the Render Output window (Fig. 68).

· In the Mode drop-down list of the Devices tab page it is possible to change definition of the output image in the LiveAction mode. If the Auto value is selected, the television standard of image (PAL or NTSC) and the color resolution depth are set according to the video adapter settings. Changing the module definition in the Mode list does not change the definition specified in the display settings in the Display Properties dialog of the operating system (Fig. 1).
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Fig. 71. Devices tab of the Render Options dialog
9 Options dialog: virtual studio general settings
The 
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 button on the HotActions main window toolbar opens the Options dialog for adjusting the application settings.
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Fig. 72. HotActions main window toolbar
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Fig. 73. Options dialog of the application settings
The Live Video tab page of the Options dialog is described in detail in the document on the video adjusting, an example of working with it is given in section 2.3.

The rest tabs of the Options dialog are described in the following sections.
9.1 LiveAction mode settings
The LiveAction Mode tab page (Fig. 74 and Fig. 75) of the Options dialog is intended for adjusting the LiveAction mode.

· It is not recommended for entry-level users to change the default settings. To restore them, click the Defaults button.
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Fig. 74. LiveAction Mode settings tab page
In the Main Window group relating to the application main window you can set the following parameters of the LiveAction mode:

Always On Top
places the application main window always above the windows of other applications;

Maximize to Fullscreen

maximizes the application main window to the full screen;
Hide Menu
hides menus in the application main window;

Hide Toolbars
hides all toolbars in the application main window apart from the LiveAction and Project panels;

Hide Status Bar
hides the status bar in the application main window.
The Render Window group (output of the result scene image) allows adjusting the following parameters:

Disable Fullscreen in single-monitor configuration

disables switching to the fullscreen mode in a single-monitor configuration. At that the Fullscreen option in the View menu of the Render Output window becomes unavailable.

Switch to Fullscreen

enables switching the Render Output window to the fullscreen mode at switching to the LiveAction.
The Debug Output group parameters:

Hide Output window

hides the Debug Output window in the operating mode;

Disable all Output (no logging)


 completely desables all output to a log file (see 9.3).
The Project group parameters allow setting the view mode of the project window.

Disable Closing
disables capability of closing a project in the LiveAction mode;

Show Normal
displays the project window in the regular way;

Show Minimized
minimizes the project window;

Hide
hides the project window.
The Scenes parameters group sets the scene windows view:

Show Normal
displays scene windows in the regular way;

Show Minimized
minimizes scene windows;

Hide
hides scene windows.
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Fig. 75. LiveAction Mode settings tab page
· Note that the above parameters concerning the windows displaying mode are actual only at the first switching of a project to the LiveAction mode. After a project is switched to the LiveAction mode and then saved, its windows’ state in this mode is also saved in the project. Later on the saved state has a higher priority than the parameters set in this tab page.
The Action Libraries group parameters allow determining the size of the Action Library window in the LiveAction mode:

Show Normal
displays the library window in the regular way;

Show Minimized
the library window is minimized;

Hide
the library window is not displayed.

The Hotsets group parameters allow specifying the necessary settings for Hotsets:
Auto-run actions in ‘Startup’ folder


auto-runs the Actions located in the $STARTUP$ folder;

Always open if included in Project


automatically displays (maximizes) windows of all Hotsets at switching to the  LiveAction mode.

The ‘Startup’ Folder Name text field is intended for setting the name of the folder (Hotbar) containing the Startup Actions in Hotsets. Actions in folders with such name are executed automatically every time at switching to the LiveAction mode (see sections 3.1.9 and 3.4.6).

The Default button restores the default values of all parameters.

9.2 Default Directories settings
In the Default Directories tab page (Fig. 76) you can specify the directories for searching files of different types (projects, icons, media files, Action Libraries, etc.) used by the application at work with any project. These paths are system for the application.
Files of any type used at work with projects are searched in the following order:

1. In the current project folder, i. e. in the folder where the project file (*.vsp) is saved.

2. In the directories marked as additional ones in the project for a particular file type (Fig. 51, on the right). Note that if at the project saving the additional directories are located on the same disk drive with the project, the search is performed by relative paths.

3. In the folders of full system paths specified in the Default Directories tab page for a particular file type (Fig. 76).

· It is very important to specify a directory correctly. Since only names of files attached to a project are saved in it, the described algorithm of search is used at opening any file included in a project.
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Fig. 76. Default Directories tab of the Options dialog
If the required file is not found by any path specified for it, the application displays an error message like one in Fig. 52. If then you specify the correct path to the file, it is automatically added to the list of additional project paths and saved at the project saving.

If the application does not find graphics, audio and other media files referred to in script commands, it also generates an error message. When the Errors option is enabled (see section 9.3), these messages are displayed in the Debug Output window (Fig. 77).
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Fig. 77. Error messages: files specified in commands are not found
Video file error message is also displayed if the file is damaged (‘VideoFile.avi’ in Fig. 77). For more detailed information about operations with media files, see the Script commands User’s Guide.
9.3 Debug Output settings
The Debug Output tab page of the Options dialog (Fig. 78) contains control options of the messages that will be displayed in the Debug Output window at work with the application.
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Fig. 78. Debug Output tab of the Options dialog
According to the options selected in this tab page the following messages can be displayed in the Debug Output window:
Errors 
error messages;

Warnings
non-critical warnings;
Info
various information about loaded data, program modules, etc.;

Runtime (from Actions)


user messages about Actions execution (see the Script commands User’s Guide, section 8, the SYS.OUTPUT command for displaying such messages);

Script Trace 
information about the course of Action commands execution; it is used for scripts debugging;
Debug Messages
various debugging messages about the application work (this option is mainly intended for the developers);

System Debug Strings


system debugging information (it is also intended for the developers): if this option is enabled, the application traps and displays all debugging messages of the applications running in the Windows and using the OutputDebugString system command;

General (No type)
 all other (not typified) messages.

The None and All buttons allow the user to enable or disable all the options simultaneously.

The icons on the left of each option correspond to the icons that will also be displayed in the Debug Output window (see section 6), to the left of the message text according to its type. Thus, the icons identify the types of messages. 

The Log File Name field is used for specifying the name of a log file for logging the messages of all selected types. A text file with this name will be created in the Windows directory for temporary files of the current user. The default file name is HotActions.log. Messages of all selected types are registered in a log file at work in the application whether the Debug Output window be opened or closed. The path to the Windows directory containing temporary files of the current system user can be found in the Environment Variables dialog. This dialog is opened as follows:
· Right-click on the My computer icon on the Windows desktop.

· In the opened context menu select the Properties command, in the opened System Properties dialog choose the Advanced tab (Fig. 79, on the left) and press the Environment Variables button.

· In the Environment Variables dialog place the mouse cursor on the User variables for ... list (Fig. 79, on the right), where the current user name is specified in place of the ellipsis.

· Find the variable named Temp in the Variable field. The Value field of this variable displays the path to the Windows temporary files directory, where the log file for the debugging messages will be located.
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Fig. 79. Advanced tab page with the Environment Variables button (on the left) 
and the dialog of the same name (on the right)
A log file with a list of the required debug messages can be sent to the developers in case of problems in order to perform fault tracing and debugging. Possible problems and solutions are described in the following section.
9.4 Language tab
The Language tab page of the Options dialog (Fig. 80) is intended for selection of the language for work in the application. The text of information messages, menu items, prompts and user controls will be displayed in the selected language.
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Fig. 80. Language tab of the Options dialog
The language list presented in this tab page depends on the components included in the application installer intended for usage in a particular country.

· Names of all languages are always displayed in English.

After changing the language and exiting the Options dialog by pressing the ОК button, the application should be restarted.

10 Troubleshooting
In case if there emerges a problem not described in this section, apply to the technical support service (section 10.6). To establish the cause of a problem you may need a log file with debug messages. This file is named HotActions.log by default and is located in the folder for temporary files of the current system user (about using debug messages, see sections 6 and 9.3).

10.1 Default directories problems
At the application start, a dialog for choosing a working folder, for example, for project files, icons (Fig. 81), scenes, libraries, Hotsets, graphics, audio and video files is displayed.

This dialog is displayed if Common folder with all standard working folders was not created for some reason at the application setup (or at reinstallation for updating), or if there is no folder specified in the Default Directories settings of the application (see section 9.2) for example if it was deleted.
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Fig. 81. Dialog for selecting a folder with Actions standard icons
It is possible to reinstall the HotActions in order to create the Common folder with standard working folders of the application.

If the reinstallation is not effective, or other non-standard working folders are used and the application could not restore paths to them from the register, it is possible to specify the path to a required folder in the dialog displayed (Fig. 81) or change it in the Default Directories tab page of the Options dialog (see section 9.2).

10.2 FD300 board problems
10.2.1 One or several boards not found in the system
If number of LIVE_n boards in the Input(s) drop-down list in the video settings dialog (the Live Video tab page in the Options dialog, section 2.3) does not correspond with the number of boards installed in the system, it is necessary to make sure whether the boards are correctly presented in the Device Manager dialog of the operating system. This dialog is opened in the following way: Start > Settings > Control Panel > System > Hardware > Device manager. If the boards are not found in the Sound, video and game controllers section of this dialog (the corresponding inscription Darim Vision FD300C Card is not displayed), the board most likely does not physically contact with the slot. In this case it is required to switch off the computer power supply and check whether the boards are tightly set in the slots. It is also possible that one of the boards is invalid, in this case apply to the technical support service (section 10.6).
If a board is found in the system, but is not identified as the DarimVision FD300С Card, perform the following operations:

· Delete all incorrectly installed boards from the system devices list. To execute this, right-click the icon of each board and select the Delete… command in the context menu. 

· Right-click on the section title and select Update driver in the context menu.
· The system will find new devices and install the corresponding drivers if the software was installed correctly.
10.2.2 Problem with cameras video image in programs of input video settings
If at the HotActions application start an error message (like ones in Fig. 82) is displayed, most likely the problem is caused by incorrect registration of the FD300 board(s) in the system. An error message like one in Fig. 82 on the right can also be displayed at the attempt to adjust video input or chroma key. The corresponding dialogs (the Select Video Source dialog, Fig. 7; the Input window of the KeyConfigPro dialog, Fig. 8) remain inactive even if the input and format were set correctly.
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Fig. 82. Errors caused by incorrect registration. Left: error at the HotActions start; right: error at the attempt to adjust a video input and chroma key
At working with a two-monitor configuration a message about incorrect registration of the FD300 boards (“No Registration” or “Invalid Registration”) is displayed on the monitor intended for image output. To register boards in the system correctly, it is necessary to reload a register file (*.reg) and reboot the computer.
10.3 Chroma key problems
10.3.1 Unspecified error message at opening the KeyConfigPro dialog
In some cases in the No Genlock mode the following message can be displayed at the attempt to adjust chroma keying in the KeyConfigPro dialog if the studio or the FD300 board is adjusted incorrectly.
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Fig. 83. Error message at chroma key adjusting in the KeyConfigPro dialog
The problem is most likely that there is no DVI signal on the video display board output. To solve this problem, check whether the second monitor with DVI output is correctly set and operates properly (see section 2.1).
10.4  Output video problems
10.4.1 Absence of DVM tab page in the Format dialog
If there is no DVM tab page in the Format dialog, which is opened by the button of the same name in the Options dialog (the LiveVideo tab page), change the FD300 board number in the Board Index drop-down list in the Format tab, exit the dialog by pressing the OK button, reopen the dialog and check whether the DVM tab page for the selected board is displayed. If there are several FD300 boards installed in the system, it is necessary to repeat the searching for each of them, choosing the number in the drop-down list and reopening the dialog until the DVM tab page is displayed. If the required tab page still is not displayed in the dialog, check whether the DVM module is effectively connected to the video adapter (section 11.1), and whether the monitor of image output operates correctly. 

10.4.2  Failure in DVM module settings modification in the Format dialog
If changes of the DVM module settings in the tab page of the same name in the Format dialog, which is opened from the Options dialog (section 2.3), are not displayed on the render output monitor, press the Apply button in this tab page and check whether DVM is connected with the video display board. If changes in the module settings are not saved at the Options dialog reopening, try to adjust DVM with the help of a COM port. For this purpose, connect the module with a COM port and start the DVMCP.exe setting program that is usually located in the С:\Program Files\ ForwardT Software\SLTMSrvs\Misc folder. If the adjustment doesn’t work this way, the module is probably invalid. To replace it, apply to the technical support service (section 10.6). 

At adjusting the DVM with the help of COM port, the module is entirely controlled by the DVMCP.exe program and the DVM tab page in the Format dialog, which is opened from the dialog of the НotActions Lite application general settings, becomes unavailable. Operations that should be performed in this case are described in the following section. 
10.4.3 Failure in adjustment of output video settings from the studio
If the DVM tab page in the Format dialog opened by the button of the same name from the Options dialog (the LiveVideo tab page) remains unavailable, it is necessary to switch off the computer power supply until its complete de-energization and then switch it on again.

10.4.4 Complete image absence
If the output image is not displayed on the TV monitor, check the cables connection and accuracy of connection of the DVM module to the graphics accelerator output (section 11.1).

Besides, make sure that the required mode of video conversion (Mode 1 or Mode 2 etc.) is selected in the Video Conversion drop-down list in the DVM tab page of the Format dialog (the LiveVideo tab page of the Options dialog). This dialog tab page is described in section 3.3 of the document on video settings.
10.4.5 Image is shifted to the screen side
In the DVM module settings (the DVM tab page in the Format dialog opened from the Options dialog) try to change the image offset value horizontally and vertically by the sliders H offset, V offset correspondingly (see the description of the DVM tab page in section 3.3 of the document on video settings). To see the results of changing the values in the render output window, it is necessary to press the Apply button in this tab page after making changes.
10.4.6 Output video TV format change problem
If after applying the changes of the output video format in the application settings (section 2.3 in the current document or section 3.2 in the document on video settings) the image on the output monitor starts flickering, make sure that the selected TV format corresponds with the TV format specified in the video adapter settings (section 2.2). If the formats do not correspond, change the video adapter or the application settings so that output video formats coincide. 

As a rule the flicker of the output image on the monitor that is caused by mismatch of the video adapter and the application TV formats is accompanied by a warning (Fig. 84).
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Fig. 84. Formats mismatch warning message
10.4.7 Recurring output image offset
The output image can be sharply shifted sometimes, if the DVM module receiving the DVI signal of the video display board was started incorrectly for some reason. To restore its correst operation, press the Reset DVM button in the Live Video tab page in the Options dialog (Fig. 5). In some cases a single click on this button is not enough for sharp offset effect elimination. If the problem emerges again, it is necessary to press the Reset DVM button several times.
10.4.8 Absent Render Output window at work with one-monitor configuration
Make sure that the Render Window command of the View menu is enabled (Fig. 36) and execute the Center Render Window command of the Window menu (section 7.1).
10.5 Video file playback problem
The video files playback is improper: there are many dropped frames, and the animation is played back jerkily. 

This problem may be caused by incorrect installation of the computer mainboard drivers; in this case it is necessary to reinstall them correctly.   

10.6 Technical support service
For complete consultation on all questions concerning the Virtual studio operation, apply to the SoftLab-Nsk technical support service by the following address:

vrset@sl.iae.nsk.su
SoftLab-Nsk, Novosibirsk, www.softlab-nsk.com
11 Appendix
11.1 Studio components connection scheme
The VS2000 studio supply package includes a basic system unit with completely installed and configured hardware and software. For the studio proper operation its components must be connected correctly. Use the connectors on the back panel of the system unit. 

Though connection schemes depend on a configuration, some of them are common for all configurations:

· VGA monitor used as the first monitor in Windows should be connected with the graphics adapter connector. This monitor will be used for controlling the studio performance. At present, the
PCI-E/AGP graphics accelerator supports the operation of two monitors. As a rule, the DVM module is connected to the bottom DVI connector (see below), and the top connector is used for the first monitor.
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Fig. 85. Connections of the video card and DVM of the Virtual Studio computer
(assemblage version currently supplied)
· If the accelerator is intended for work with two monitors, probably both of its connectors are digital (DVI). In this case first analog monitor is connected to the top DVI connector with a special adapter.

· In the Virtual studios of the former assemblage with the GeForce3/4 class graphics accelerators in the package, Windows first monitor was connected to the additional or built-in PCI VGA adapter (Fig. 86). In this case the 15 pin DSUB connector of the graphics accelerator should NOT be used for the VGA monitor connection.
The 15 pin DSUB connector of the built-in adapter is on the back panel where the keyboard and mouse connectors are located.
At the present time such configuration of the Virtual studios is not supplied.
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Fig. 86. Connections of the video card and DVM of the Virtual studio computer
(assemblage version previously supplied)
· The DVI output of the PCI-E/AGP (GeForce) graphics accelerator should be connected to the DVI connector of the DVM board (Fig. 85).

· Each expansion board (FD300) has to be connected to the supplied switching devices that allow connecting input and/or output video and audio signals. It can be a special cable (Fig. 87), passive (Fig. 88) or active (Fig. 91) Breakout box, or the breakout box for a system with several boards (Fig. 93).
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Fig. 87. Cable for connection of input and output audio and video signals to the FD300 board
The 28 connectors of the cable correspond to those of the passive breakout box apart from SPDIF. All connectors are marked according to the following rules.
All video inputs are divided into three identical groups for ease, each of them has the inscription Vin and a number of the input group. Each group contains 4 coaxial connectors (A, B, C, D). Depending on the device operating mode the following signals can be received on the video inputs:

· to input A (Vin1A, Vin2A, Vin3A) – CVBS-A, LUMA-AB, CSYNC;

· to input B (Vin1B, Vin2B, Vin3B)– CVBS-B, CHROMA-AB, Y, YS, G, GS;

· to input C (Vin1C, Vin2C, Vin3C) – CVBS-C, LUMA-CD, U,B;

· to input D (Vin1D, Vin2D, Vin3D) – CVBS-D, CHROMA-CD, V, R,

where:

· CVBS – composite video signal;

· LUMA, CHROMA – S-video signal constituents;

· Y, U, V – YUV component signal constituents;

· R, G, B – RGB component signal constituents;

· CSYNC – single signal of the component input synchromix;

· YS, GS – component input synchromix is contained in the Y or G constituent.

The video output connectors Blue, Red, CVBS, Green correspond to the RED/V/C, GREEN/Y, BLUE/U/CVBS and CVBS/CSYNC video outputs. Possible combinations are presented in the table (Fig. 90). For more detailed information about switching video inputs, see section 2 of the HardwareSetup document describing breakout boxes.

Audio inputs are marked: Ain1L, Ain1R; Ain2L, Ain2R; Ain3L, Ain3R.

Audio outputs: Aout1L, Aout1R; Aout2L, Aout2R; Aout3L, Aout3R, where L – left channel of stereo signal, R – right channel.

11.2 Passive Breakout box (TF782)

The passive breakout box (Fig. 88, on the left) is intended for connecting analog video and audio sources and signal receivers. It is connected to a connector on the FD300 board with a special cable (Fig. 87) supplied with the box.
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Fig. 88. Appearance of the passive breakout box with the connection cable
The front appearance of the passive breakout box is shown schematically in Fig. 89. All video inputs are divided into three identical groups, each of them has a frame with the VIDEO INPUT inscription and a number of the input group. Each group contains 4 coaxial connectors (A, B, C, D). Depending on the device operating mode the following signals can be received on the video inputs:

· to input A – CVBS-A, LUMA-AB, CSYNC;

· to input B – CVBS-B, CHROMA-AB, Y, YS, G, GS;

· to input C – CVBS-C, LUMA-CD, U,B;

· to input D – CVBS-D, CHROMA-CD, V, R.
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Fig. 89. Passive breakout box scheme
Video outputs are presented by the VIDEO OUTPUTS group, where 4 outputs (RED/V/C, GREEN/Y, BLUE/U/CVBS and CVBS/CSYNC) are located. Possible combinations are presented in the table below.
	
	VIDEO OUTPUTS group connectors

	Possible combinations
	RED
	BLUE
	GREEN
	CVBS

	Y/C+CVBS
	C(Chroma)
	CVBS
	Y(Luma)
	CVBS

	YUV+CVBS
	V
	U
	Y
	CVBS

	YUVS
	V
	U
	Y
	Sync

	RGBS
	R
	G
	B
	Sync

	YUV+Key/α
	V
	U
	Y
	Key/α


Fig. 90. Video outputs combinations table
· You must NOT receive the Y/C (S‑video) signal simultaneously from the miniDIN-4 S-VIDEO connector and GREEN (Y – brightness signal) and RED (C – color information) connectors.
· Chroma signal (С) should be loaded at 75 ohm. Some SONY equipment (monitors, videotape recorders) does NOT have such loading and this should be taken into account.

Audio signals are devided into 2 groups: output signals – AUDIO OUTPUTS, input signals AUDIO INPUTS. In each group there are six patchholes in three L-R stereo pairs.

11.3 Active Breakout box (TF785 M)
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Fig. 91.Front appearance of the active breakout box
On the active breakout box (Fig. 91) there are 3 identical channels of VIDEO INPUTS (Fig. 92

). Each channel contains four pairs of parallel-connected through-pass BNC coaxial connectors (A, B, C, D), and also 2 MiniDIN4 connectors for connection to sources of S-video (inputs AB and CD). The connectors used are selected with the COAXIAL/S-VIDEO switches. The OFF/ON switches are intended for connecting/disconnecting 75 ohm terminal resistors of the corresponding coaxial video input.

Depending on the device operating mode the following signals can be received on the video inputs:

· to input A – CVBS-A, LUMA-AB, CSYNC;

· to input B – CVBS-B, CHROMA-AB, Y, YS, G, GS;

· to input C – CVBS-C, LUMA-CD, U,B;

· to input D – CVBS-D, CHROMA-CD, V, R;

where: 
CVBS – composite video signal;


LUMA, CHROMA – S-video signal constituents;


Y, U, V – YUV component signal constituents;


R, G, B – RGB component signal constituents;


CSYNC – single signal of the component input synchromix;


YS, GS – component input synchromix is contained in the Y or G constituent.
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Fig. 92. Active breakout box scheme
When a component signal with the YS or GS constituent is sent to the channel video input, the YES/NO switch should be in the YES position. In all other cases it should be in the NO position (normal position).

On the box there are also four video outputs (RED/V/C, GREEN/Y, BLUE/U/CVBS, CVBS/CSYNC) combined into the VIDEO OUTPUTS functional group. Each video output is duplicated, which allows connecting a preview monitor simultaneously with the working signal.

Six patchholes grouped in three L-R stereo pairs form AUDIO INPUTS functional group. All audio inputs are balanced, for which three-pole stereo plugs are used. The OFF/ON switches are intended for connecting/disconnecting 600 ohm terminal resistors of the corresponding audio input. 

The AUDIO OUTPUTS functional group is formed by six balanced audio outputs. They can be used as unbalanced ones with the earth connection of one balance line, the same way as audio inputs.

In the AUDIO MONITOR HEADPHONE group there is a patchhole for stereo headphone connection. The output level can be specified by the VOLUME controller. The number (1, 2 or 3) of an audio output for listening is selected by the SELECT switch. The MODE switch allows setting the necessary mode: LR – stereo, LL – left channel only, RR – right channel only.

The POWER light-emitting diode indicator shows the power supply availability.

· If the POWER LED indicator is not alight after the FD300 board is connected to the active breakout box, apply to the technical support service (section 10.6).

11.4 Breakout boxes for a system with several FD300 boards (TF783 A, TF783 B, TF783 C)

If several FD300 boards are installed in the system and it is desirable to perform all necessary connections of audio and video sources and signal receivers on the same breakout box, the TF783 A, TF783 B or TF783 C boxes can be used for this purpose (Fig. 93). 
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Fig. 93. Front appearance of the breakout boxes for connecting several FD300 boards
As a rule, the TF783 A Breakout box is used in systems with two FD300 boards for video data input and with option of synchronazation of output video signal to an external device. At that the VIDEO INPUTS 1 (A, B, C, D) and VIDEO INPUTS 2 (A, B, C, D) groups are intended for connecting video sources to the first board decoders, the VIDEO INPUTS 3 (A, B, C, D) and VIDEO INPUTS 4 (A, B, C, D) groups – for connecting to the second board, the VIDEO INPUTS 5 group – for connecting the external synchronization device. Video outputs are presented by the VIDEO OUTPUTS group: RED/V/C, GREEN/Y, BLUE/U/CVBS and CVBS/CSYNC. Input AUDIO INPUTS and output AUDIO OUTPUTS audio signals are always connected to the FD300 board intended for signals output.

The TF783 B Breakout box and TF783 С Breakout box are usually used only for input signals connection. 

The cable used for connecting a breakout box to the FD300 boards is also supported in the package with the breakout box (Fig. 94). 
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Fig. 94. The cable for connecting FD300 boards with the breakout box
The cable branches are intended for connection with the FD300 boards. Usually there are color marks or numbers at the ends of branches for determining the correspondence of connection to the boards. A connection type is usually determined by the current system configuration file with the *.cfg extension located in the С:\Program Files\ForwardT Software\FDConfig folder next to the FDConfig.exe file. The name of this file should be selected in the Breakout Box Cable Connectors drop-down list in the FD300 Configuration application. All available configuration files are also usually located in the C:\Program Files\ForwardT Software\FDConfig\CableInfo folder.
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